Install .NET Framework Versions


Install .NET Framework Versions

You need to install the .NET Framework to run many apps on Windows. The best versions to install are the latest one and the .NET Framework 3.5 SP1. Those two versions should run nearly all apps.

    After installing the .NET Framework, run the app again. It should run as expected. If you see the same error message again, you may need to install a different .NET Framework version than the one you installed. It is safe to install multiple versions of the .NET Framework on your computer.

    Developers may want to check out .NET Framework SDKs and Targeting Packs and Targeting .NET Framework Versions to learn more about targeting .NET Framework versions.