Building apps with the .NET Framework 4.5.1 Preview in Visual Studio 2012

This post describes how to add targeting support for the .NET Framework 4.5.1 in Visual Studio 2012. It was written by Rich Lander, who worked on the original multi-targeting support in Visual Studio 2010.

Here’s the question:

clip_image002

You can. Visual Studio 2013 preview provides built-in support for targeting the .NET Framework 4.5.1 Preview, but you can also build apps that target the .NET Framework 4.5.1 using Visual Studio 2012.

Here’s the short answer:

clip_image003

The .NET Framework 4.5.1 Preview includes the .NET runtime, but doesn’t include the files needed by Visual Studio to build .NET 4.5.1 apps. Instead, there is a separate download that includes all of the reference assemblies, IntelliSense XML files, and anything else needed to provide a great targeting experience in Visual Studio. We call this download a targeting pack.

You can get the targeting pack in these two ways:

  • Either install Visual Studio 2013 Preview on your machine that already includes Visual Studio 2012. You’ll be able to target .NET 4.5.1 from both versions of Visual Studio.
  • Or install the Windows 8.1 Preview SDK, which includes the targeting pack. The next time you open Visual Studio 2012, .NET 4.5.1 will be available from the target framework list.

For future reference, this information is also listed on .NET Framework SDKs and Targeting Packs for Visual Studio 2012. Our Get the latest .NET bits post explains how you can get to the SDK and targeting pack pages, for each version of Visual Studio.

Thanks for all the interest in and feedback on the .NET Framework 4.5.1 Preview.