PSScriptAnalyzer v1.4.0 release and support on PSv3.0

Hello All.

The first ScriptAnalyzer release of year 2016 added the ability to run on platforms containing PowerShell versions 3.0 and above. This means that Windows Management Framework (WMF) 5.0 is no longer a dependency to use ScriptAnalyzer.

ScriptAnalyzer v1.4.0 (available in PowerShellGallery), ships with binaries compatible on systems containing PSv3.0/4.0 and PSv5.0 and loads the correct supported version. Rule functionality  automatically adapts to underlying PowerShell . For example – Rules that validate PowerShell Classes get triggered only on PSv5.0.

In the latest release – v1.4.0 we have added new rules, fixed reported bugs and improved experience for people who use VSCode PowerShell plugin by emitting accurate extents for script issues.

To get additional information, please refer to the release notes for v1.4.0 here:
https://github.com/PowerShell/PSScriptAnalyzer/releases/tag/1.4.0

To download the release, from PowerShellGallery, follow the link:
http://www.powershellgallery.com/packages/PSScriptAnalyzer/1.4.0

As a side-note, we have ScriptAnalyzer integration with ISE-Steroids add-on and have published a standalone ScriptAnalyzer ISE add-on too.

And finally, thank you all – “The Community” for your feedback, contributions to code and documentation, rule suggestions, ideas, discussions and everything else.

Raghu Shantha (@raghu_shantha)
Senior Software Engineer
PowerShell ScriptAnalyzer Team
https://github.com/PowerShell/ScriptAnalyzer