Update JEA for the April WMF 5.0 Preview

This year, at the Ignite Conference, we presented Just Enough Administration (JEA), a PowerShell toolkit for granularly managing administrator privileges.  Older versions of JEA do not work with the recently released  April WMF 5.0 Preview.  This is due to an issue with WinRM when registering a new endpoint.  The latest version (0.2.16.6) of JEA contains a workaround, and is available in the PowerShell Gallery.  Please install this version of the module to use JEA with the April WMF 5.0 Preview.

If you are updating an existing system with JEA to the April WMF 5.0 Preview, please take the following actions:

  1. Update the xJEA module to version 0.2.16.6 (e.g. “Update-Module -Name xJEA”)
  2. Delete the “C:\Program Files\Jea” folder

Once you have updated xJEA, you may notice the following error showing up when applying configurations using the xJeaEndpoint resource.  This error may be safely ignored.

WARNING: [WSManNetworkFailureDetected] The network connection to JEA-demo1 has been interrupted. Attempting to reconnect for up to 4 minutes…

WARNING: [WSManConnectionRetryAttempt] Attempting to reconnect to JEA-demo1 …

WARNING: [WSManConnectionRetrySucceeded] The network connection to JEA-demo1 has been restored.

The WS-Management service cannot process the operation. The operation is being attempted on a client session that is

unusable. This may be related to a recent restart of the WS-Management service. Please create a new client session

and retry the operation if re-executing the operation does not have undesired behavior.

+ CategoryInfo : InvalidOperation: (root/Microsoft/…gurationManager:String) [], CimException

+ FullyQualifiedErrorId : HRESULT 0x803381fa

+ PSComputerName : JEA-demo1

VERBOSE: Operation ‘Invoke CimMethod’ complete.

 

We apologize for any confusion or inconvenience this may have caused.  Thank you,

John Slack
Program Manager
PowerShell Team