Missing App URL Suffix after importing app via a solution

I recently ran into an issue with a customer that wasn’t well documented, so I wanted to share via our blog in case others run into this issue.

Scenario: My customer created an application in v8.2 (Works the same in v9) and added an App URL Suffix so that they could access the app directly by going to https://<crm instance name>.crm.dynamics.com/Apps/<AppName>.  Next, they wanted to move that app via a solution file up to a higher instance (ie: Dev to Test).  They created a solution file and added the App and sitemap to the solution.  They exported the solution and imported into the higher instance.

Result: The application imported successfully.  However, the App URL Suffix was blank and greyed out so that they couldn’t add it back in the App Designer | Properties area.

This is “by-design” as there isn’t currently a way to detect if that App URL Suffix is already in use in the destination instance.  So, we clear this out and you can still access your application by going to the My Apps area, but just not directly via the URL above in the source instance.  I have submitted a bug to get this experience improved in the future and also logged a CRM Idea that could use your vote.  https://ideas.dynamics.com/ideas/dynamics-crm/ID0003757

Workaround: The good news is that there is a workaround that exists in both v8.2 and v9 today.  You can go to the My Apps area (https://<crm instance name>.crm.dynamics.com/Apps) | Locate your App | Select “Manage Roles” | Expand “App URL Suffix”.  From there you can enter the desired URL in the destination instance, save and publish.   This will allow you to access your app directly from your URL again like you did in the source instance.

Hopefully this helps to get you out of the same jam that I was in with my customer this week.

Shawn Dieken

Follow the conversation:
@pfedynamics | http://www.pfedynamics.com

Comments (0)

Skip to main content