Project Online: Provisioning a new PWA with PowerShell

This post comes from my “You learn something new every day” collection – and after responding to e-mail saying the only way to provision a PWA site in Project Online is through the UI I thought I’d better double check.  I’d also seen a Twitter posting about a new update to the SharePoint Online Management Shell that came out yesterday – so what better time to install it (after uninstalling the previous one) and giving it a test drive.

Here is the download -

There are no specific Project PowerShell commands there – I quickly established that hadn’t changed (gcm *PWA* and gcm *Project*) but what about New-SPOSite?  Maybe if I use the PWA#0 template?  But how would I enable the PWA features (I had my on-premises hat on…).

So this is what happened…  First step – Connect-SPOService – and the Url is the admin page – not just the tenant page:


Then I used the New-SPOSite command – with the following parameters:

New-SPOSite -Url -Owner brismith@brismithpjo -StorageQuota 20 -Title BlogPWAFromPowerShell -Template PWA#0


Then went over to my Admin Center to take a look:


And once the provisioning was complete – what would I find?


A working PWA site!  I’m sure plenty reading this are saying “yes, of course” and already knew this – but it had somehow passed me by.  There isn’t unfortunately a way to set permissions mode via PowerShell – as far as I could see anyway – but happy to proven wrong.  It would make a great addition to Set-SPOSite.

I did notice that Set-SPOSite does already have an EnablePWA option – but having executed it against a SharePoint team site it didn’t seem to do what I expected (Add PWA) – so I’ll try and find out more,. as the example on the Set-SPOSite docs page is a little lacking.

Comments (0)

Skip to main content