Release of SDK Preview 0.8.0.0 and Runtime Preview 5.5.0.2 for Linux


We have released a minor update to our  runtime and SDK preview on Linux, versions 5.5.0.2 and 0.8.0.0 respectively. This update contains several bug fixes and improvements.

This change is a breaking release since clusters with previous runtimes will not be upgraded to 5.5.0.2, and your Java code will need to be recompiled. For more details, see the release notes.

To update from a current version of the SDK and runtime on your developer environment, run the following steps (remove SDKs from the list that you hadn't installed and don't want to install):
    sudo sh -c 'echo "deb [arch=amd64] https://apt-mo.trafficmanager.net/repos/dotnet-release/ xenial main" > /etc/apt/sources.list.d/dotnetdev.list'
    sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 417A0893
    sudo apt-get update
    sudo apt-get install servicefabric, servicefabricsdkcommon, servicefabricsdkcsharp, servicefabricsdkjava

If you are installing for the first time, you will also need to run the following command (before any of the commands above are run):

    sudo sh -c 'echo "deb [arch=amd64] http://apt-mo.trafficmanager.net/repos/servicefabric/ trusty main" > /etc/apt/sources.list.d/servicefabric.list

For updating the CLI, navigate to the directory where you cloned the CLI and run a git pull for updating.

Highlights of this release include Jenkins integration, EventSource integration for C# templates,  Eclipse plugin improvements and more.

 

Cheers,

The Service Fabric Team


Comments (2)

  1. Jose says:

    This does not work because servicefabric package depends on dotnet-dev-1.0.0-preview2-003131.
    Please upgrade this to depend on the already release dotnet-dev-1.0.0 package.

    Thank you.

  2. Tom Gowallis says:

    I get access denied when i try and run the first command.

Skip to main content