Release of SDK 2.4.164 and Runtime 5.4.164 for Windows


This release is a refresh of the 2.4 SDK and 5.4 runtime with the usual small updates: Bug fixes and various minor improvements to performance and stability. Some highlights of this release include:

  • Fix for FileNotFoundException when taking back-ups of Actor Services.
  • Improvements to application upgrades.
  • Improved support for asynchronous application type registration.
  • Fix for unhealthy nodes during cluster downscaling.
  • Fix for Visual Studio 2015 and Visual Studio 2017 side-by-side installations.

As always, please refer to the full release notes for all the details.

Cheers,
The Service Fabric Team


Comments (10)

  1. Reinhard says:

    Guys, please note that the version will not work in german language. I started VS in german and couldnt open the project (System.AggregateException: Mindestens ein Fehler ist aufgetreten. ---> Microsoft.Assumes+InternalErrorException: The specified default content type (Default) is not defined) -> switched to english and it worked

    1. Sorry about that, this has been fixed in the latest SDK release.

  2. João Pinheiro says:

    Hey! I got here a bit of a struggle on remotely calling services through service proxy:

    ServiceProxy.Create(new Uri("fabric:/MyApp/MyService")) does not support generic interfaces.

    For us to have way better class libraries for controllers and services, this would be a great improvement!
    Thanks in advance.

  3. Paul Baumgartner says:

    I'm having serious issues using the Web Platform Installer to install this SDK. I've installed the Azure SDK and Tools 2.9 without issues, but this one refuses to install. It keeps throwing "File not found" HRESULTs in the .MSI log for the Service Fabric Runtime. As a result, the consecutive 2 packages also then fail to install. Are there any other prerequisites for this SDK?

  4. Alex says:

    Links to *.msi missing in release notes! Please share.

  5. John Arlando says:

    After upgrading the SDK to 2.4.164 from 2.0.217, we're facing problem to load the service fabric project. Do we need to perform any extra operation to open the project in visual studio? Visual studio tries to upgrade the sfproj file every we open the solution but it fails. An error is displayed "An error occurred during upgrade. The project will be restored to its original state. Invalid URI: The URI is empty."

  6. egmkang says:

    hello, i'm very interested in Service Fabric. i'd like to know, can i write one C# micro service which can run on the Linux ?

  7. alex says:

    The direct download for this is not in the release notes. I need the direct download as this version does not show up in the web pi anymore.

  8. Aakash Pawar says:

    Do we have any links to download the Sdk version 2.4.164. Because from Web platform installer it is showing me the latest version where in my project requires 2.4 version.

    1. We added 2.4.164 back to Web Platform Installer for you. Hope that helps!

Skip to main content