App Verifier for WM5


I just got word that we released a version of App Verifier that works on Windows Mobile 5 devices.  Here’s the link:

http://www.microsoft.com/downloads/details.aspx?FamilyID=d275348a-d937-4d88-ae25-28702c78748d&displaylang=en

App Verifier is a tool you can use to check for memory leaks in applications you’re writing.  It’s been around for a while, but previously didn’t work on WM5.

Mike


Comments (13)

  1. Magne Roald says:

    Can I use this to test my application on real WM5 devices with Visula Studio 2005, or can it only be used with the platform builder?

  2. Nino.Mobile says:

    TGIF!  (sort of..  I’ll be working through the weekend yet again..*sigh*).   Oh yeah,…

  3. Winson Ho says:

    Hi, I am trying App verifier with VS2005 program. and Device Emulator. But my .map file can not match App Verifier log, it will display ?? to indicate the leak. Do you know what’s wrong?

  4. Myime says:

    "App Verifier that works on Windows Mobile 5 devices"

    does it work on Winodws Mobile 5.0 Emulator?

    Thanks.

  5. hepower says:

    Hi, I am trying App verifier with VS2005 program. and Device Emulator. But my .map file can not match App Verifier log, it will display ?? to indicate the leak. Do you know what’s wrong? i have the same problem

  6. ditta says:

    I am also having the same problem as Winson Ho and hepower in that the app verifier is not resolving the function addresses to symbols using the supplied map file.

  7. map file says:

    I have the same problem? is there anything need to be noticed when generate the map file?

  8. Jeff says:

    Is there an app verifier available which will run on a Windows Mobile 2003 SmartPhone?

  9. mygogo says:

    I had the same problem, the .map file name seen from the Output Window of Visual Studio 2005 is incorrect.

    Maybe codes generated by VS2005 are different from eVC4, or other reasons?

  10. sardo007 says:

    I can’t get the AppVerifier connected to the device… it hangs as soon as the connection process starts. I have the device configured for both Transport and Startup Server using Active Sync. The connection process launches the appverif_client but it seems not to be running properly…

    I’ve tried a QTek S200 and a Grundig GR980 and both behave the same way…

    Pls could you give me any link to AppVerifier discussion or FAQ?

  11. priyanka_GL says:

    I can’t get the AppVerifier connected to the emulater for both Pocket PC and Smartphone devices… it hangs as soon as the connection process starts. I have the device configured for both Transport and Startup Server using Active Sync.Could someone pour in their thoughts regarding this?

  12. Milton says:

    I could not let app verifier resolve the function addresses to symbols using the supplied map file.

    It looks like many people have the same problem as me.

    Is there any way to solve it? 🙁

  13. Ajay says:

    Application verifier does not resolve function names. It shows it as UNKNOWN!UNKNOWN. Tried putting map file in Windows as well as Release folder.

    Is there anyway to manually resolve dependencies by going through map file?