Introduction for Zainab Hakim – An update


Hi all,


It was recently pointed out to me that I had not yet updated my introduction post. So I wanted to take a moment to let you all know of a change in my job description and role. Since October 2008, I have been the Program Manager (commonly known as PM at Microsoft) for Windows Installer. I’m excited about my new role and its been a great journey so far. Thank you for your continued interest in the Windows Installer and I look forward to your comments and feedback as always.


Hi, I’m Zainab (pronounced Zay’nab) and I am the test engineer for the Windows Installer (MSI) team. I have been a part of the MSI team for just a little under 3 years now. I love coming in every day to my job and working on the technology that significantly affects a variety of customers worldwide and enables them to provide a great installation and configuration experience of their applications.


I served as the test lead for Windows Installer 4.5 out-of-band release, which is the latest release of Windows Installer. This article describes all the new and improved features of Windows Installer 4.5. 

Comments (8)

  1. Next Generation Application Model?

    Oh you have to say more on that! 🙂

    Usually when I hear words like that, I’m thinking Web 2.0 which doesn’t have a whole lot to do with Windows let alone Windows Installer.

  2. steve says:

    The team blog refers to Windows Installer

    V 4.5.6000.22162 for Vista SP3 but the download

    appears to install as V 4.5.6000.20817

    (i.e. for RTM).

    Unfortunately the filename does not specify the

    build and properties does not show the version.

    Can you please provide a link where 22162 for x86

    is available for download as I am getting Event ID

    1039 when I use this version.

  3. Bryan Edwards says:

    Tells me I do not have enough space and refuses to load

  4. mhusen says:

    Help! – I have installed v4.5 for XPpro-sp3.

    For some reason, the Win Installer service does not start automatically even though it is set on "auto" in "services".  I have to start the service manually each time the Win Installer is required by going into the services, clicking on "properties" & then clicking on "start", it then works ok.  This problem was also encountered with previous version of the Win Installer – it started about 3months ago.

    Please advice how to rectify the problem so that the Installer service starts automatically on boot & re-boot.

    Thanking you in anticipation.

  5. Lucifer says:

    Hi Zainab.

    After looking around a bit, especially late at night, did you find any traces of zombies or vampirism in installer team?

    The general impresssion from the world outside is that those people are awfully weird!

  6. Ever since the Installer 4.5 was downloaded on my machine – XP SP3 – the Automatic Updates feature will not install after the download is complete.

    Could someone tell me how to correct this error.

    I have the Automatic Updates set to Notify me but not to download or install.

    This used to work OK with the 3.1 installer.

    Thanks in advance for your assistance.

  7. Last week at Microsoft’s Global MVP Summit I had the opportunity to sit down with the MSI and WiX teams