Configurando .NET Core 1.1.0 (current) en Windows


Cuando instalamos las herramientas de .NET Core para Visual Studio, aparte del tipo de proyecto se instala también el SDK y el runtime. Pero la versión del SDK no es la más reciente, sino la versión LTS (Long Term Support). Dedicada para aquellos que con el fin de tener un soporte extendido de 3 años prefieren sacrificar las últimas innovaciones que se vayan liberando. Sin embargo, la evolución de .NET Core continúa permanentemente y se están publicando versiones estables que tienen hasta 3 meses de soporte.

Esta es la filosofía en Windows. Pero en Linux y Mac, las opciones por defecto siempre instalarán la última versión estable.

Así que si en Windows queremos estar a la vanguardia, existen un par de pasos adicionales que necesitamos para quedar con la última versión estable que a Enero de 2017 es la 1.1.0.

La versión 1.1.0 del framework requiere trabajar con una versión de Nuget mínimo 3.4.4. Esto, con el fin de que Nuget pueda configurar bien los archivos del proyecto Net Core de acuerdo a la última versión. Si en el about de Visual Studio se observa una versión menor a 3.4.4:

image

 

Entonces lo primero que hay que hacer es actualizar a la última (clic en la imagen para ir al destino):

image

Después de esto, procedemos a descargar el .NET Core 1.1 ( o el que se encuentre “current” a la hora de leer este artículo).

image

 

Obsérvese que como queremos desarrollar, se escoge el SDK y no solo el runtime. Solo escogeremos el runtime, para instalarlo en una máquina cliente por ejemplo.

Acto seguido, ejecutamos la instalación del SDK:

image

Ahora, si usamos Visual Studio, procedemos a la creación o modificación de nuestro proyecto .NET Core que queremos tener en la última versión del framework. Y si vemos el archivo de configuración project.json observaremos que en la sección de dependencies, tiene una estructura similar a esta:

"dependencies": {
  
"Microsoft.NETCore.App": {
    
"type"
: "platform",
    
"version": "1.0.1"
   }

Aquí se nota que por defecto Visual Studio trabaja con la versión LTS. Por ahora no hay una forma visual para decirle a Visual Studio que trabaje con la versión 1.1.0 o la última estable. Ojo que no basta con cambiar la versión en el archivo de configuración. Es necesario hacer el upgrade a través de Nuget; que como ya está actualizado a la última versión, sabrá cómo actualizar el proyecto para que quede funcionando correctamente. Así que hacemos la actualización a través de Nuget:

 

image

Después de esto, entre otras actualizaciones tendremos la del project.json:

"dependencies": {
  
"Microsoft.NETCore.App": {
    
"type"
: "platform",
    
"version": "1.1.0"
   }

Con lo que ya quedaríamos listos para correr nuestra aplicación con la última versión del .NET Core Framework.

Encuentra en mi Github un ejemplo muy sencillo de una aplicación de Consola .NET Core corriendo con la versión 1.1.0 del framework:

Image result for github png logo

Comments (0)

Skip to main content