Installation of an MSI package shows "Assembly Error: The assembly is built by a runtime newer than the currently loaded runtime, and cannot be loaded." error

While working on a customer case involving a Windows installer based package, we came across an interesting issue that was preventing the installation of the MSI package on a particular computer. The setup failed with the following error message that we captured from a verbose log. Error message: Assembly Error: The assembly is built by…

0