You must use the Role Management Tool to install or configure Microsoft .NET Framework 3.5.

While trying to install Visual Studio 2008 on a Windows 2008 R2 machine you may get the following error. This is because Windows 2008 R2 ships with the .NET 3.5.1 framework. You just need to enable the feature from Server Manager. So before starting the Visual Studio 2008 Setup install the .NET Framework 3.5.1 Features…

68