Visual Studio 2008 setup fails with "Error 1935: An error occurred during the installation of the assembly……."


Sometimes this error occurs if windows update is scanning for updates at the same time as Visual Studio setup is installing components.


Workaround 1:

Reboot your machine and restart Visual Studio 2008 setup.

 
Workaround 2:

 If Workaround 1 doesn’t work,

1. Reboot the machine

2. Disable windows update (start menu -> windows update)

3. Restart VS setup

4. When VS Setup is done, enable windows update (don’t forget this step!)

 

If you run into any problems with either installation or uninstall, please make sure to post in the Visual Studio 2008 Setup and Installation Forum on MSDN.

 

Hope that helps.

 
Varun

 


Comments (18)

  1. hatim says:

    hi

    i did, stoped windows update service and rebote my machine but still same problem

    please HELP

    thanks

  2. Lee says:

    I have the same issue!

    On my machine I know it’s down to the manifest file being just full of spaces instead of containing XML. The file in question is C:WindowsWinSxSmanifestsx86_policy.8.0.microsoft.vc80.mfc_1fc8b3b9a1e18e3b_8.0.50727.762_none_8a14c0566bec5b24.manifest

    The main Problem is the file is protected by Windows, so I can’t even overwrite it.

    Best of luck!

    Lee.

  3. Pedro Dias says:

    I have the same problem – disabling Windows update did not help me. I can’t delete the files Lee mentioned, but they’re not empty either, and seem ok.

    Windows 7 here, 64 bit. I thought this error was due to me installing Expression Studio, so I uninstalled expression + vs2008, and now I can’t get anything to install.. very, very, very frustrating issue!

  4. 3stones says:

    Thank you for the tips. The 2nd method worked for me. System installed: Win7 ultimate 64bit on Core 2 Dual laptop.

  5. fran says:

    first during the step "Microsoft Visual Studio 2008" the installer dies on:

    Executing action: HxMerge_VSIPCC_VSCC_x86_enu

    (msiconfig, Normal Startup)

    next, i reboot, but with windows installer enable and Remote Procedure Call enable. (msiconfig, with Selective Startup)

    next, i try install, but get this error.

    what are the services that i need?

    (i dissable windows upday just now )

  6. Brian says:

    This HELPED and it worked!

    http://support.microsoft.com/kb/872904

    I read to the bottom of the article, and saw,

    "If the .NET Framework 1.0 is not installed correctly on your computer, you may notice the behavior that is mentioned in the "Symptoms" section. Therefore, make sure that the installation of the .NET Framework 1.0 is complete before you try to install Visual Studio .NET."  

    WOW!  You need 1.0 installed?!  WTF? I installed 1.0, and bingo-bango, it worked.  

  7. dimitrischris says:

    I REBOOTED THE SYSTEM AND TURNED OFF AVG ANTIVIRUS AND THE INSTALLATION CARRIED ON…

  8. khan says:

    Plz help me, i am installing visual todio 2008 proffessional edition on windows xp service pack 2. the setup starts but when reach to "Microsoft visual studio 2008" component it stops and gives an error message "Visual Stodion 2008 Proffessional Edition- ENU error…." and setup exits. i have installed windows xp sp2 recently nothing else is installed on my machine…………. plz give me ur precious suggestions.

    thanks

  9. Paul says:

    VS 2008 on Vista Home produced this same error for me. However, as another suggested… installing Framework 1.1 and a reboot did the trick.

  10. Paul says:

    FYI… I left my AVG running but DID disable Adaware

  11. Khan, let me know if you are still running into the same issue. Try 'temporarily' disabling the AV and running the installation.

  12. grevan says:

    I was unable to turn off udates, but managed to complete install after forced reboot than, second reboot.  Not sure what was causing the problem in the first place, but that got me passed it anyhow.  

    thanks

  13. grevan says:

    I was unable to turn off udates, but managed to complete install after forced reboot than, second reboot.  Not sure what was causing the problem in the first place, but that got me passed it anyhow.  

    thanks

  14. Nemanja says:

    Hi guys! I faced same issue during VS2010 installation. I had installed VS2010 Professional, uninstall it and tried to install VS2010 Ultimate. Now I cannot finish this task because of error message that getting.

    I installed Msizap.exe and executed command 'Msizap TP {B43357AA-3A6D-4D94-B56E-43C44D09E548}' but face same error message again! In cmd I got message that there is no files were found. Is it necessary to have installed older versions of .NET framework (1.1, 2.0, 3.0 and 3.5) if I have installed last version 4.0? In this moment I have installed all mentioned versions, only 1.0 missing and it is not possible to install it because system recognizes 1.1 as newer version and don't allow installation of old one. Tried to uninstall .NET framework and install it again, but it didn't solve my problem, same error message again…

    Do you know what can be reason for so weird behavior???

  15. Hi Nemanja,

    Can you contact me on varun_logs at *hotmail* *dot* *com*

    I'd like to discuss what you are seeing a bit more.

    Regards,

    Varun

  16. knightluffy says:

    Works for me after reboot and disable the windows update service and set the status to disable.

  17. Rambabu says:

    I have successfully installed Visual Web Developer 2008 Express on Windows 7 Ultimate

    Note:

    Install .NET Framework 1.1 before running Setup file