Five Silly Mistakes To Make When Installing Longhorn

As anyone who got the Longhorn developer bits at the PDC should have had well drilled
into them – this is a developer preview release. This is the earliest in the
product cycle we’ve ever given out bits without requiring stringent NDAs, to the best
of my knowledge (although the first beta of Windows 2000 – Windows NT 5.0 as it was
known at the time – was pretty ropey too). You have to treat pre-beta bits with special
tender-loving care: they’ve not had widespread testing on the broad array of machines
that exist out there in the real world. I should know this by now, having played around
with a few earlier internal builds over the last couple of months. How then did I
manage to make so many stupid mistakes when trying to install Longhorn on my machine?!

Here are five lessons I’ve learnt – in the vain hope I can save someone else from
making the same basic errors!

  1. Make sure your notebook is not attached to a docking station when you install Longhorn.
    This is something that most notebook manufacturers call out in the manual that nobody
    reads; in my case, when I rebooted Longhorn it wasn’t able to detect the external
    monitor, which resulted in all kinds of amusing efforts to blindly shut Windows down
    from a laptop keyboard that could only just be opened without breaking the docking
  2. Don’t bother installing it as a Virtual PC image unless you have a seriously well-specified
    machine; certainly not if you plan to play around in any depth with the sample applications
    that ship as part of the SDK. By well-specified, I mean a machine with more than 1GB
    RAM, a 3GHz processor, and ideally a separate hard drive / controller for the Longhorn
    image. I could swear that I heard the sound of laughter from my laptop when I fired
    up Longhorn for the first time as a Virtual PC image. (On the other hand, installing
    Windows Server 2003 / Whidbey / Yukon works a treat in a Virtual PC, and I’ve been
    using this combination quite happily since spring.)
  3. Don’t install the Longhorn SDK until you’ve installed Whidbey – if you want the integrated
    Longhorn support in Whidbey, that is. In my favour, the instructions for this aren’t
    exactly obvious – they’re buried deep within the Longhorn SDK release notes – and
    who on earth reads that kind of thing? 🙂 Having installed these two in the wrong
    order, I tried reinstalling the Longhorn SDK, but the designer support was still missing
    from Whidbey. In the end, I gave up and flattened the partition (again).
  4. Make sure you’ve got a valid product key ahead of time if you’re going to install
    Longhorn via the bootable CD. There’s nothing more frustrating than getting half-way
    through the setup process only to discover that the pesky 25-character activation
    code is only available online. At least we’ve now moved it a little earlier in the
    process than was the case with previous OS releases. Time for yet another reboot…
  5. If you think it’s hung, wait twenty minutes and come back before presuming it’s completely
    dead. If you’re in the hardware detection phase of setup and are using Virtual PC,
    try waiting overnight! If you think this is unacceptable, try waiting for Beta 1!

Being on the “bleeding edge” has risks – but also plenty of rewards. I’m looking forward
to getting to the rewards bit soon…

Comments (3)

  1. Anonymous says:

    Painful? Oh yes. Installed it on my DP p3/700 last night. 12hrs. 12 hrs to install! :Eeek: And it was SO SLOW after :S

  2. Anonymous says:

    I can certainly attest to the problems with installing it in a VM. And forget about installing it on a laptop as well. The hard drives are too slow, and the bus speeds on most are well behind similar desktop and/or server machines.

    Having gone through the pain of installing in a VM, I bit the bullet and ordered a new server from Dell for my Longhorn playground. Details at

  3. Anonymous says:

    worked fine for me in vmware4.0…. took about 30 minutes to install on my athlonxp2000+ with a half gig of ddr266…