KB2531907 – Validate SCSI Device Vital Product Data (VPD) test fails after you install Windows Server 2008 R2 SP1


If you are running a cluster with Windows Server 2008 R2 SP1 and three or more nodes you should install this KB.

KB Link: http://support.microsoft.com/kb/2531907

Symptoms

Consider the following scenario:

  • You configure a failover cluster that has three or more nodes that are running Windows Server 2008 R2 Service Pack 1 (SP1).
  • You have cluster disks that are configured in groups other than the Available Storage group or that are used for Cluster Shared Volumes (CSV).
  • These disks are online when you run the Validate SCSI Device Vital Product Data (VPD) test or the List Potential Cluster Disks storage validation test.

In this scenario, the Validate SCSI Device Vital Product Data (VPD) test fails. Additionally, you receive an error message that resembles the following:

Failed to get SCSI page 83h VPD descriptors for cluster disk <number> from <node name> status 2

The List Potential Cluster Disks storage validation test may display a warning message that resembles the following:

Disk with identifier <value> has a Persistent Reservation on it. The disk might be part of some other cluster. Removing the disk from validation set.

Resolution

The following hotfix resolves an issue in which the storage test runs on disks that are online and incorrectly not in the Available Storage group.
The error and warning messages that are mentioned in the “Symptoms” section may also occur because of other issues such as storage problems or an incorrect configuration. Therefore, you should investigate other events, check the storage configuration, or contact your storage vendor if this issue still occurs after you install the following hotfix.

 

Taylor Brown
Hyper-V Enterprise Deployment Team
taylorb@microsoft.com
http://blogs.msdn.com/taylorb

WS08R2-HyperV_v_rgb

Comments (4)

  1. Jesse Cain says:

    I have this senario but I do not have SP1 installed. Could you tell me a fix for that? I have not seen anything yet except for SP1 installed.

  2. Eric Anderson says:

    Still have both issues on 2008 R2 SP1 after the hotfix. As far as I can tell it didn't do a single thing to fix the problem. The system was FULLY supported prior to SP1 but now the validation tool says it isn't, no hardware changes whatsoever. The only change was from RTM to SP1.

    Failed to get SCSI page 83h VPD descriptors for cluster disk 1 from node "xxxx" status 2

  3. Jesse as you do not have SP1 installed have you taken a look at the following KB?

    support.microsoft.com/…/978562

    "The "Validate Multiple Arbitration" test on a Windows Server 2008 R2-based failover cluster may incorrectly fail

  4. Abdul says:

    Hi, I have the same issue but with Windows Server 2012 R2

Skip to main content