SharePoint Server 2016 – Installation and Deployment

Bill Baer introduces the new SharePoint Server 2016 describing the initial investments made in installing and deployment. There’s guidance on system requirements, deployment scenarios & prerequisites.  A new MinRole feature is also explained (with a short, to-the-point video).  He also throws light on health rules & compliance and Upgrade & Migration options. Read his blog…


Remote debugging tip on Windows Server 2012 R2

As most of you know, my role primarily involves debugging and debugging a lot!  Most often I prefer Visual Studio debugger for debugging managed code.  That of course, if the problem I am trying to find the root-cause of is reproducible.  Well, if I don’t have that luxury, then there are other approaches (memory dumps…

1

The new “Custom Script” (no-script) feature

The purpose of this post is to increase awareness on Custom Script (a.k.a. no script) feature that’s introduced in O365 SharePoint tenants.  We’ll be able to see this option when we visit SharePoint Admin Center site > Settings and scroll down to see the Custom Script section.   I “boxed” the more information link intentionally…

2

Unable to create 2013-platform workflows through SharePoint Designer 2013

I recently hit another “flavor” of this problem when trying to create a 2013-platform workflow using SharePoint Designer 2013.  Whenever I choose to create a workflow using 2013-platform, the dialog box will vanish just as though it’s about to create the workflow designer for me and then the “Downloading data” dialog shows up for a…


SharePoint Online: Client libraries not loaded in publishing pages

Recently worked with a customer who had JSOM code in a content editor web part.  They had this web part deployed to a page on their SharePoint Online publishing site.  For simplicity, let’s say they had the below code in a JS file referenced in their content editor web part. <script type="text/javascript">   ExecuteOrDelayUntilScriptLoaded(spCallOut, ‘SP.js’);…

1

Register-SPWorkflowService throws InvalidData, DirectoryNotFoundException on 15TEMPLATEWorkflowActivities directory

I was setting up a new SharePoint 2013 environment and hit this issue when registering workflow manager with SharePoint 2013.  Thought I’d share this out so that it helps others who might run into this issue. Here’s the sequence of my installation. 1. Installed SharePoint 2013 RTM + SP1 and then SharePoint 2013 November CU…