Workaround for uninstall error "The Microsoft .NET Framework 2.0 is not installed. Please install before running setup."


Some users have been reporting an error they see when trying to uninstall SQL Express, this error says, “The Microsoft .NET Framework 2.0 is not installed.  Please install before running setup.”

Since SQL Setup leverages .NET for all SKUs, the workaround is to re-install the .NET Framework 2.0, uninstall SQL Server Express, then uninstall the .NET Framework 2.0 if desired.

 


Comments (3)

  1. rustvibe says:

    I have .NET 2.0 already installed (as it says when trying to re-install it) as part of Vista SP1.  But still can’t install SQL Express 2008 because of this error….   hrm…

  2. sqlexpress says:

    Answer for rustvibe:

    Is this a question about installing SQL Express 2008 or uninstalling SQL Express 2005? The blog post is about uninstalling SQL Express 2005 so isn’t relevant if you’re not doing that.

    If you’re trying to install SQL Express 2008 read the two most recent posts in this blog for more information about the requirements.

    - Mike