SQL Express Beta 2 coming soon


The full Beta 2 version of SQL Express is coming soon.  While the Beta 2 release will not add any new features, it does contain many bug fixes that were not in the Tech Preview.  We recommend upgrading to Beta 2 as soon as it is available.<?xml:namespace prefix = o ns = “urn:schemas-microsoft-com:office:office” />

Unfortunately, the Beta 2 build requires a later build of the .NET Framework than the Tech Preview.  You will need to uninstall the 2.0 Framework and download the updated version from the Express download page before attempting to install Express Beta 2.  Also, SQL Express Beta 2 and Tech Preview builds cannot be installed side by side on the same machine.  This means that if you have Express installed you will need to uninstall all the Tech Preview components before attempting to install Beta 2.  You can find a preview of the download page instructions below:

·  Step 1: Use Add/Remove Programs to remove any earlier version (lower than 9.00.852) of SQL Server 2005 components (if any). Remove all of the following components (if exists) in the same order as listed below:

  • Microsoft SQL Server Yukon” Beta 1

  • Microsoft SQL Server 2005 Beta 2

  • Microsoft SQL Server 2005 Express Edition Beta 2

  • Microsoft SQL Server 2005 Tools Beta 2

  • Microsoft SQL Server 2005 Tools Express Edition Beta 2

  • Microsoft SQL Server 2005 Data Transformation Services Beta 2

  • Microsoft SQL Server 2005 Analysis Services Beta 2

  • Microsoft SQL Server 2005 Notification Services Beta 2

  • Microsoft SQL Server 2005 Reporting Services Beta 2

  • Microsoft SQL Server Setup Support Files

  • Microsoft SQL Native Client


Note: It is not necessary to remove previous versions of SQL Server such as SQL Server 2000, SQL Server 7.0 or any earlier versions.

·  Step 2: Use Add/Remove Programs to remove Microsoft .NET Framework Versions 1.2 or 2.0, if installed.

Note: It is not necessary to uninstall Microsoft .NET Framework Versions 1.0 and 1.1.

·  Step 3: Download and install the Microsoft .NET Framework 2.0 available at Microsoft .NET Framework 2.0 download center page.

·  Step 4: Install SQL Server Express by clicking the Download button on the upper right corner of this page. SQLExpr.exe is a self-extracting installation package of SQL Server Express. Save SQLExpr.exe file to your computer.

Comments (20)

  1. Brad Raulston says:

    So will this break the VS 2005 Beta 1 install or can they coexist?

  2. Euan Garden says:

    No this will not break VS Beta 1, it does include a very slightly later version of the framework than VS does, but the later version is an incremental build.

    -Euan Garden

    Product Unit Manager

    SQL Server Tools

  3. Brad Raulston says:

    So as a rule we should reinstall both SQL 2005 and VS 2005?

  4. Euan Garden says:

    Nope, the plan would be follow Brians steps, but leave VS on the machine, re-install .Net and SSE and all should be well.

    VS Express SKUs will work with the updated Frameworks included with SQL Server 2005 Beta 2.

    -Euan Garden

    Product Unit Manager

    SQL Server Tools

  5. Brad Raulston says:

    Good to here

  6. SQL Server 2005 Express Beta 2??( bug fix ?)???? NET Framework 2.0 Beta 1 (x86) ?

  7. Jason says:

    Can you please state the exact 4 part build of .net beta 2 that is required

  8. ccv says:

    hi,

    I downloaded SQL 05 from microsoft’s site

    http://www.microsoft.com/downloads/details.aspx?FamilyId=62B348BB-0458-4203-BB03-8BE49E16E6CD&displaylang=en

    But when I installed it, I could not load it up. I could not find the Microsoft Management Console ?

    Any ideas what I am doing wrong ?

  9. Euan Garden says:

    What do you mean you could not load it up?

    In a command window try the following:

    sqlcmd -S.sqlexpress

    If this connects then SSE is running. To find Computer Manager there should be a short cut in Start Programs Microsoft SQl Server 2005

    -Euan Garden

    Product Unit Manager

    SQL Server Tools

  10. gang li says:

    After setup SSE, I try to install PetShop 3.0. It complains it can not aceess model database. I checked model has no any system tables. What is going?

  11. DniceMaki says:

    please remove me from the Beta Testing