SharePoint 2013 : Unable to view/edit Office documents in browser using Office web apps 2013


In a SharePoint library, Unable to view/edit Office documents in browser using Office web apps. You get below error

 

“Sorry, something went wrong. An error occurred on the server."

clip_image001

This is due to the Fact that Dell changeAuditor Tool installed on SharePoint server doesn't support Office Web Apps integration with SharePoint.

 

# Looking at the ULS logs on SharePoint servers , Found exception as below

 

Application Authentication          aiv3c                Exception            System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at net.pipe://localhost/SecurityTokenServiceApplication/appsts.svc that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.    Server stack trace:      at System.ServiceModel.Channels.ConnectionUpgradeHelper.DecodeFramingFault(ClientFramingDecoder decoder, IConnection connection, Uri via, String contentType, TimeoutHelper& timeoutHelper)     at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.SendPreamble(IConnection connection, ArraySegment`1 preamble, TimeoutHelper& timeoutHelper)     at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.DuplexConnectionPoolHelper.AcceptPooledConnection(IConnection connection, TimeoutHelper& timeoutHelper)     at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)     at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)     at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)     at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)     at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout) 

 

Application Authentication                agmxo  Exception            System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at net.pipe://localhost/SecurityTokenServiceApplication/appsts.svc that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.    Server stack trace:      at System.ServiceModel.Channels.ConnectionUpgradeHelper.DecodeFramingFault(ClientFramingDecoder decoder, IConnection connection, Uri via, String contentType, TimeoutHelper& timeoutHelper)     at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.SendPreamble(IConnection connection, ArraySegment`1 preamble, TimeoutHelper& timeoutHelper)     at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.DuplexConnectionPoolHelper.AcceptPooledConnection(IConnection connection, TimeoutHelper& timeoutHelper)     at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)     at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)     at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)     at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)     at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)     at System.ServiceModel.Channels.ServiceChannel.CallOnceManager.CallOnce(TimeSpan timeout, CallOnceManager cascade)     at System.ServiceModel.Channels.ServiceChannel.EnsureOpened(TimeSpan timeout)

 

Found that Dell ChangeAuditor is configured.

Stopped the ChangeAuditor agent and did an IISRESET.

Browsed to the SharePoint library and now users were be able to view/edit Office documents in browser using Office web apps.

Dell is already aware of this issue, refer to article below for more details

https://support.software.dell.com/change-auditor/kb/150602  

 

Post By: Anoop Prasad [MSFT]


Comments (2)

  1. Valy Greavu says:

    Thank you very much! I spend more than 24 hours to find this solution. Stupid stupid implementation of Dell ChangeAuditor!!!

    I receive a similar error when I was trying to publish a SharePoint 2013 Workflow from SharePoint Designer and stopping this Dell service make my publishing to works! The error from publishing stage contains: net.pipe://localhost/SecurityTokenServiceApplication/appsts.svc.

    Thank you again!

  2. Thank you so much! I spent over 17 hours straight trouble shooting this, and went home in dismay. I did some more googling and found this article after I had gone home. The next day, I came in and was able to get past the net.pipe EndPointNotFound Exception, and eventually get my OWA working. Thank you!

Skip to main content