Supportability and Vista UAC


Supportability is a topic near and dear to my heart.  Vista has made great leaps and bounds in this area  with more logging than any prior OS, as well as a great help file and improved errors.


 However, the other day I was playing with Vista’s UAC features and manifests and noticed an error which doesnt really give an indication as to what the real issue is so I thought I would note it here.


When I launched an application with a valid manifest I would get this error:


 


  


 


The error really didnt tell me much but I did recall that I had set some UAC policies earlier  in this domain.


 Under Security Options—  User Account Control: Only elevate executables that are signed and validated



 


Ahhh this was the culprit. Sho’ nuff , I reverted this and it all worked out.  However, had someone asked me why they got an error “A referral was returned from the server” in relation to a UAC issue – I never would have guessed this was the cause…


 Maybe it’ll help someone someday..


spatdsg

Comments (7)

  1. Johnny says:

    That doens’nt work mate.

    I’ve disabled those features but i still get the error message.

    Any other reasons why this could be?

  2. SpatDSG says:

    Unfortunately without more info I cant begin to tell you why it may be popping that error.

  3. Kumar says:

    Thanks for your information….i tried this and worked for me

    With regards

    Kumar.M

  4. Pete says:

    I turn UAC off and on next boot it is back on. How can I stop this?

  5. Thank you, I didn’t realize the implications of switching this on.

  6. DUIT Dale says:

    This helped me today!  Thanks a ton for sharing this.