Setup fails when you attempt to install Enterprise Portal with SysDevelopmentProxy (object) has no valid runable code in method ‘generate’ error


Setup fails when you attempt to install Enterprise Portal If the .NET Business Connector is not installed on the Microsoft Dynamics AX client computer when the initialization checklist is run, then the SysDevelopmentProxy class is not compiled. If this class is not compiled, Setup fails when you attempt to install Enterprise Portal.


 


To compile the SysDevelopmentProxy class, open the AOT > Classes node, right-click SysDevelopmentProxy, and click Compile. If you receive a compile error, then the .NET Business Connector is not installed. Install the .NET Business Connector using Setup, and then compile the AOT (Right-click the AOT root node and click Compile).Once you compile this successfully, then proceed to EP setup.


 


 


Below is the error that you would see in the setup log file. Don’t get confused with the last line in the error log as Reason: No .NET Business Connector session could be found. The real issue is the one reported above about SysDevelopmentProxy (object) has no valid runable code in method ‘generate’ error.





… 


Deploying proxies…
In SysEPDeployment::deployProxies…
In SysEPDeployment::clrGetVirtualServerProxyDir…
 
Entering function GetConfigurationFilePath
 Leaving function GetConfigurationFilePath
 
 C:\Inetpub\wwwroot\wss\VirtualDirectories\<portnumber>\App_Code\Proxies
In SysEPDeployment::clrGenerateProxies…
 Error executing code: SysDevelopmentProxy (object) has no valid runable code in method ‘generate’.



 


(C)\Classes\SysDevelopmentProxy\generate
(C)\Classes\SysEPDeployment\clrGenerateProxies – line 7
(C)\Classes\SysEPDeployment\deployProxies
(C)\Classes\SysEPDeployment\deployAllWebParts
(C)\Classes\SysEPDeployment\deployEPOnSharepoint
(C)\Classes\SysEPDeployment\installEnterprisePortal



Microsoft.Dynamics.BusinessConnectorNet.BusinessConnectorException
   at Microsoft.Dynamics.BusinessConnectorNet.AxaptaObject.Call(String methodName, Object[] paramList)
    at Microsoft.Dynamics.BusinessConnectorNet.AxaptaObject.Call(String methodName, Object param1)
    at Microsoft.Dynamics.Framework.BusinessConnector.Session.DynamicsObjectAdapter.Call(String methodName, Object param1)


An error occurred during setup of Role Centers and Enterprise Portal.
Reason: No .NET Business Connector session could be found.
=== Rolling back setup of Role Centers and Enterprise Portal due to error ===
Launching MSI:  /i “D:\Msi\Components32\Components32.msi” /qb-! /l*v “C:\Documents and Settings\All Users\Application Data\Microsoft\Dynamics AX\Dynamics AX Setup Logs\<Date Time>\Components32 Rollback Log.txt” DIRECTEXECUTE=1 SETUPLANGUAGE=EN INSTALLDIR=”C:\Microsoft Dynamics AX\50″ INSTALLDIR32=”C:\Microsoft Dynamics AX\50″ ADDLOCAL=”ClientUI,EnterprisePortal,NetBusinessConnector,ClientConfig” REMOVE=”EnterprisePortal”
=== Rolling back setup of Role Centers and Enterprise Portal due to error ===
Rollback of === Rolling back setup of Role Centers and Enterprise Portal due to error ===


 installation has been completed. For details about why the installation failed, see the previous messages in the log.



 === Setup was canceled or failed. For details see the previous messages in the log.

Comments (8)

  1. Dennis says:

    Hi,

    When I Compile the SysDevelopmentProxy class I get 2 errors. Message: Errors found in Class SysDevelopmentProxy. 1 is a syntax error in the property "generate" and 1 is Microsoft.Dynamics.Framework.BusinessConnector.ProxyGenerator.Pg does not contain this function. Any idea’s why this happens??

    I have got 3 servers (all 2003 R2 SP2) in test environment: 1 SQL 2005 Sp2 DB, 1 AX server and 1 IIS server + MOSS 2007. The only server where I need to install the .net BC is the webserver I believe. Any suggestions for me??

    Thx.

    Dennis

  2. Nitesh says:

    I am getting same error , even After Compiling and Synchronizing the entire Application.

  3. Ryno says:

    Compile and sync on a computer with Business Connector installed on it. This solved my problem.

  4. Hans says:

    Thanks to Ryno for the idea of compiling it on the target server – seems you have to do this on each & every server that you want EP on.

    Now still struggling with conflicts with the remnants of the v4 EP on the same server – "can’t create the web site".

  5. When installing Enterprise Portal for Dynamics AX 2009 one of the most often reported reasons for a failing

  6. H Ksrikanth says:

    Error when trying to modify the user control

    EPCSSCheckOut, EPCSSCheckOut;

    When clicking the Axgroup properties collection, the following error is displayed.

    Dynamic Object Adapter call Failed;

    No .Net Bussiness Connector session could be found

  7. Frankie.Zhao says:

    WOW, you gave me the real solution, thanks so much