Anwendungen sehen auf einmal Ihre DLL’s nicht mehr


Hallo zusammen,

Folgendes Szenario:

Der Kunde nutzt in seinem ganzen Unternehmen App-V 4.6 auf den Windows 7 x64 Fat Clients und auch auf den Windows 7 x64 Notebooks. Nun kommt es vor, dass nur auf den Notebooks verschiedene Anwendungen melden sie seien nicht korrekt installiert und es fehlen DLL Dateien.

Wie hier zu sehen:

image

Wenn man sich von so einem Start einen Procmon Trace erstellen lässt, dann sieht man folgendes:

clip_image003

An diesem Pfad (in diesem Fall V:\SAPR3GUI.720\SAPgui\sapshlib.dll) ist diese DLL aber wirklich und auch nachweislich vorhanden (sonst würde es die ganze Zeit ja schon nicht gehen).

Ein Löschen der PKG Dateien – hilft nicht.

Löschen des App-V Caches – hilft nicht.

Neuinstallation des App-V Clients (nach bereinigung aller Ordner) – hilft nicht.

Komplette Neuinstallation des OS – hilft (wenn auch nur kurz)

Ursache / Lösung:

Nachdem ich mich dem Fall angenommen habe, habe ich einen „Fat“ Client und einen Notebook Client verglichen und festgestellt, dass auf dem Notebook Client ein Proxyclient von der Firma Blue Coat installiert ist, welcher ein Modul mit dem Namen Easyhook64.DLL verwendet.

Wenn man den ProxyClient Service von Blue Coat stoppt gehen die Anwendungen wieder, schaltet man es diesen wieder ein, so hat man auch das Problem wieder. Sprich das „Hooking“ von Blue Coat kommt unserem „Hooking“ in die Quere…

Nun liegt der Fall bei Blue Coat.

Schönen Gruß und allen Lesern ein frohes und gemütliches Weihnachtsfest.

Sebastian Gernert – Support Escalation Engineer

Comments (0)

Skip to main content