Fehler 0A-200001F4 auf einigen App-V Clients


Hallo zusammen,

nach einem sehr langen und schwierigen Fall tut es manchmal gut seine Erfahrung gleich niederzuschreiben…

Folgende Fehlermeldung wurde von einigen Kunden im SFTlog.TXT gesehen:

Der Berichtsdatencache von Application Virtualization Client konnte nicht an die Veröffentlichungsserver-URL ‘rtsp://AppV-Server:554/’ gesendet werden (Rückgabecode = 1690670A-200001F4)

Zudem landet dieser Eintrag im Eventlog:

Event Type:       Warning
Event Source:    Application Virtualization Client
Event Category: (51)
Event ID:           3144
Date:                12/05/2010
Time:                14:17:34
User:                N/A
Computer:         AppV-Client
Description:
{tid=254:usr=adm}
The Application Virtualization Client report data cache could not be sent to Publishing Server URL ‘rtsp://AppV-Server:554/’ (rc = 1690650A-200001F4).

Im Verzeichnis in dem die FSD liegt (c:\Users\All Users\Public\Documents) kann man sich die versteckten Dateien anzeigen lassen und findet dort evtl. sehr viele XML Dateien. Das sind die Informationen die nicht in der Datenbank von App-V abgelegt werden konnten und somit das Reporting verfälschen.

In einem Verbose Server Log wird folgendes geloggt:

[2010-05-28 15:23:20.259] AppV-Server 13268 18112 SW_SQLDataConnection::BindParameters – "Default Provider" adm – 5 65535 "Got NULL value for non-nullable parameter."

[2010-05-28 15:23:20.259] AppV-Server 13268 18112 SW_SQLDataConnection::ModifyRecord – "Default Provider" adm – 5 65535 "Failed to bind values to statement."

[2010-05-28 15:23:20.259] AppV-Server 13268 18112 ProcessReportingData – "Default Provider" adm-julians – 5 65535 "Failed to modify package information in the database"

[2010-05-28 15:23:20.259] AppV-Server 13268 18112 SW_RTSPHandler::SendResponse – "Default Provider" adm – 5 65535 "Response: [RTSP/1.0 500 Internal Server Error]"

[2010-05-28 15:23:20.275] AppV-Server 18156 16276 SW_CoreEventHandler::handle_input – – – – 5 65535 "Received command 0x3 from dispatcher."

[2010-05-28 15:23:20.275] AppV-Server 18156 16276 SW_ConnectionManager::CreateConnection – – – – 5 65535 "Create Connection (776)"

[2010-05-28 15:23:20.275] AppV-Server 18156 16276 SW_ConnectionManager::CreateConnection – – – – 4 42263 "RTSP connection established. Client IP: 10.21.81.1:3886

LÖSUNG

Wir haben uns das das SFTNTA.Log und Netzwerk  Traces angesehen und dabei festgestellt das für ein Paket der  Wert “Name”, der im Packages Key  Registry hinterlegt ist, leer übergeben wird.

<PKG_DATA Name="{E5062850-E2E4-49CD-A6ED-0517835AA35A}" Guid="{E5062850-E2E4-49CD-A6ED-0517835AA35A}" Ver="3" VerGuid="{3E27F130-A1D2-4118-B388-2A5FD42B6156}" Source="RTSP://%SFT_SOFTGRIDSERVER%:554/Office_2003/Office_2003_MNT_3.sft" PctCached="100"/>

<PKG_DATA Name="" Guid="{D2E2345D-0D28-4C66-98AC-A07726818088}" Ver="7" VerGuid="{0CF18E20-2578-4908-AF74-DC4E237A3000}" Source="RTSP://%SFT_SOFTGRIDSERVER%:554/7_ZIP/7_ZIP.sft" PctCached="100"/>

Wenn man diesen Wert mit der GUID des Pakets füllt ist das Problem weg, man kann natürlich auch irgendetwas reinschreiben.

Um das ganze abzukürzen, bitte bei diesem Problem die einzelnen Packages im Packages Key ansehen und nach dem suchen wo der Wert Name leer ist.

Sebastian Gernert – Support Escalation Engineer

Comments (16)

  1. Andreas Konrad says:

    Danke für den wertvollen Hinweis. Mir stellt sich die Frage, warum der "Name" in der Registry leer ist? Ist das Verhalten auf ein nicht befülltes Element im OSD-File zurückzuführen? Bzw. was passiert, wenn ich alle leeren Namen fülle und irgendwann alle Anwendungen aus dem AppV-Client lösche und das Cachefile zurücksetze und die Anwendungen neu lade? Ist der Wert dann wieder leer?

    MfG

    Andreas

  2. S Gern says:

    Das ist die gretchen Frage – Beim Config Mgr. ist uns eine Möglichkeit bekannt wir das passieren kann (Override URL) Problem. Bei einem Reset des Caches würde der Name bei dem neu laden befüllt sein. Es ist kein Fehler der Pakets, soviel wissen wir. Aber die genauen Umstaände warum auf einmal auf einigen Clients der NAME leer ist, ist uns nicht bekannt, da nicht so leicht nachzustellen um Daten zu erheben.

    Schönen Gruß

    Sebastian

  3. Andreas Konrad says:

    Sehr merkwürdig. Gestern habe ich einen unserer Terminalserver per Imaging-Verfahren neu aufgesetzt und bereits heute morgen ist das Name Attribut des ersten Pakets (Acrobat Reader 9.3.3) leer. Die Gegenprobe auf einem Testserver, der bislang kein einziges Package geladen hatte zeigte allerdings, dass hier nach dem ersten Start desselben Acrobat-Pakets der Name befüllt ist…

    Gruß

    Andreas

  4. Andreas Konrad says:

    Hi Sebastian,

    gibt es in diesem Fall neue Erkenntnisse? Auf unseren TS sind ständig etliche "Namen" der Packages in der Registry leer.

    Beste Grüße

    Andreas

  5. S Gern says:

    Hallo Andreas,

    Wir haben hier ja mehr Probleme:

    1. Der Name wird geleert und es werden keine Reporting Daten hochgeladen = 3144 Meldung.

    2. Nachdem der Name gesetzt wird werden neue aber keine Alten Reporting Daten auf den Server geladen.

    Aktuell haben wir Scripts die es erlauben Daten mit leerem Namen in die Datenbank zu laden. Da wir das Problem bisher nicht nachstellen noch die Ursache ermitteln konnten. Somit sind zumindest die Reporting Daten im der Datenbank und man bekommt keine 3144 Fehlermeldungen.

    den Inhalt dieser Scripts kann ich leider noch nicht posten, ich werde das aber abklären um diese dann hier posten zu können.

    Schönen Gruß

    Sebastian Gernert

  6. Andreas Konrad says:

    Hallo Sebastian,

    sind die Scripts mittlerweile zugänglich oder gibt es eine alternative Lösung für die Problematik?

    Grüße

    Andreas

  7. S Gern says:

    Hallo zusammen,

    gibt es jemanden der den aktuell letzten Hotfix für seine App-V Version schon installiert hat also:

    mindestens:

    4.5 SP1 HF3

    4.5 SP2 HF1

    4.6 RTM HF2

    4.6 REFRESH HF1  

    Schönen Gruß

    Sebastian Gernert

  8. Andreas Konrad says:

    Hallo Sebastian,

    unsere App-V Clients laufen unter Version 4.6.0.20200. Der Managmentserver unter 4.5.3.19480.

    Gelten die Hotfixes ausschließlich für Clients und Sequencer? Welche Version ist derzeit die aktuellste für den Management-Server?

    Den Client werde ich testweise mal auf 4.6.0.30051 akutalisieren.

    Gruß und schönes WE

    Andreas

    AnAndreas

  9. S Gern says:

    Hallo Andreas,

    die Version 4.6.0.30051 ist in Deinem Fall genau die Richtige um zu testen.

    Mgmt. Server ist SP2 – also Deine Version die aktuellste.

    Schönen Gruß

    Sebastian Gernert

  10. Andreas Konrad says:

    Kurzes Feedback: Im Bezug auf den Fehler 0A-200001F4 (Eventid 3144) schafft das Hotfix Package 1 für den 4.6er Client leider keine Abhilfe.

    Vorgehensweise: HF1 installiert, alle App-V Anwendungen entfernt inkl. Cache Reset, unmittelbar nachdem sich die ersten User wieder am Terminalserver angemeldet haben sehe ich die bekannten Fehlermeldungen im Eventlog.

  11. S Gern says:

    Danke Andreas,

    und in diesem Fall ist auch der "NAME" Wert in einem (einigen) Packages leer.

    Konntest Du das verifizieren?

    Schönen Gruß

    Sebastian

  12. Andreas Konrad says:

    Hallo Sebastian,

    richtig, es gibt weiterhin Packages, die einen leeren Wert "Name" haben.

    Gruß

    Andreas

  13. S Gern says:

    Hallo Herr Konrad,

    bei anderen Kunden hat ein Hotfix mit dem Override URL Fix das Problem behoben. Ich würde empfehlen an dieser Stelle eine Anfrage zu eröffnen, damit wir dem Problem bei Ihnen auf die Schliche kommen können.

    Was halten Sie davon?

    Schönen Gruß

    Sebastian Gernert

  14. Andreas Konrad says:

    Hallo,

    sehr gern. Gibt es etwas zu beachten bei der Calleröffnung?

    Grüße

    Andreas

  15. S Gern says:

    Hallo Herr Konrad,

    Erwähnen Sie meinen Namen in der Problembeschreibung dann kommen Sie etwas schneller zu mir. Ansonsten gibt es nichts weiter zu beachten.

    Schönen Gruß

    Sebastian Gernert

  16. Mike says:

    Dies wurde soviel ich weiss von Microsoft später mal gelöst. Hier die Loesung mit Screenshots.

    http://www.butsch.ch/…/APPV-46-client-Event-3144-and-no-Reporting.aspx

Skip to main content