Failure to establish PIC connectivity to MSN


 


Symptoms:


 


LCS 2005, OCS 2007, and/or OCS 2007 R2 fail to establish PIC connectivity to MSN after changes were made to the MSN infrastructure on May 9, 2009


 


 


Data:


 


In the logs, you’ll see the following data:


 


TL_ERROR(TF_CONNECTION) [1]08B4.146C::05/12/2009-15:32:27.115.00004bcf (SIPStack,SIPAdminLog::TraceConnectionRecord:1224.idx(157))$$begin_record


LogType: connection


Severity: error


Text: Receive operation on the connection failed


Local-IP: 167.207.100.260:2540


Peer-IP: 65.54.227.249:5061


Peer-FQDN: federation.messenger.msn.com


Connection-ID: 0x375D101


Transport: TLS


Result-Code: 0x80072746 WSAECONNRESET


$$end_record


 


TL_ERROR(TF_CONNECTION) [1]08B4.146C::05/12/2009-15:32:27.115.00004bde (SIPStack,SIPAdminLog::TraceConnectionRecord:1224.idx(157))$$begin_record


LogType: connection


Severity: error


Text: The connection was closed before TLS negotiation completed. Did the remote peer accept our certificate?


Local-IP: 167.207.100.260:2540


Peer-IP: 65.54.227.249:5061


Peer-FQDN: federation.messenger.msn.com


Connection-ID: 0x375D101


Transport: TLS


$$end_record


 


 


Cause:


 


The old VIP is being cached in your environment somewhere.   If you look at the logs, connections are still trying to be made against 65.54.227.249, yet this VIP has been turned off on the MSN side.


 


Federation.messenger.msn.com is currently being directed to 64.4.9.181, though per Microsoft KB 897567, there are 5 possible IP addresses.  At this time the 64.4.9.181 IP address is the only one in service (and the other IP addresses listed in the article will be brought online as load/capacity deems necessary).


 


 


Resolution:


 


Clear the DNS cache (or HOSTS file), as they are resolving to the wrong IP address.


 


 


Credit:


Nathan Novak (in MSN; he rocks!)


 


 

Comments (7)

  1. DrRez says:

    We are MS insiders working to help build a strong OCS/UC network on Twitter in advance of OCS Wave 14.  I would like to point to (tweet) your blog posts to our following of 380 OCS/UC-related folks, who will then tweet to their followings. Do you have a Twitter account?

    subrad@microsoft.com

  2. Pedro says:

    Hi Scott i have the same problem, i checked the DNS resolution and it seems to be working fine… i have federation only with yahoo and private companies… what should i do??

  3. Hi Pedro,

    What is your domain name?

    Scott

  4. Alistair says:

    Good post. This really helped me out as had old  host entry which was causing issues. Could see traffic comming in to edge but not going out.

  5. Matt at'a bank says:

    we are seeing some strangness with Yahoo PIC, but only when or LCS2005 pic user is speaking with his Yahoo! contact  when said contact is using yahoo! "webmessanger or blackberry Yahoo!"

    Presence doesnt seem to update, and messages sem to be homes to the yahoo hard client regardless of where the Yahoo! contacts last home point is..

    just wondering if this is a known isssue? "

  6. mattt at'a Bank says:

    sorry bout the spelling

    monday morning hotdog fingers.