Visual Studio Compatibility and Vista


Somasegar blogged last week about the availability of a beta release of SP1 for Visual Studio 2005 so go check out the details.  Anticipating questions from some of my customers I have captured some toplines here relative to the supportability of different versions of Visual Studio and the new OS Vista due out end of year.  So:



  • Visual Studio 2002 & 2003 - NOT SUPPORTED

  • Visual Studio 2005 - supported with SP1

Visual Studio 2005 natively supports the .NET Framework 2.0 and will utilize add-ins to support the .NET Framework 3.0, Windows Vista, and Office 2007.  Vista will ship with the .NET Framework 3.0 pre-installed.   .NET 1.1 applications will run on Vista but their development using VS2003 will not be supported.


</steve>


Skip to main content