How to install or upgrade SAP Systems to SQL Server 2016 *updated*

On 4/10/2016, SAP released support for SQL Server 2016 for some SAP NetWeaver based systems. In this blog we will talk about how you can update your existing installations on SQL Server to SQL Server 2016, what you need to do when installing a new SAP NetWeaver based system on SQL Server 2016 and what to consider when upgrading an SAP NetWeaver based system which is already running on SQL Server 2016. We will also list all supported products and the required Support Package Stacks.

On 9/12/2016, SAP updated SAP Note 2201059 (Login required) and the Product Availability Matrix (PAM) to include most SAP products based on SAP NetWeaver 7.0 ABAP and higher. See below for an updated list.

SQL Server RDBMS DVD

Important: Please read SAP Note 2139358 (Login required) and SAP Note 2313067 (Login required) on more information about how and where to download the SQL Server 2016 RDBMS DVD.

Installation of SAP NetWeaver

The following SAP NetWeaver based products are currently supported on SQL Server 2016:

  • SAP products based on SAP NetWeaver Java for releases SAP NetWeaver 7.0 or higher
  • Update: SAP products based on SAP NetWeaver ABAP for releases SAP NetWeaver 7.0 and higher
  • SAP NetWeaver PI for releases SAP NetWeaver 7.0 and higher
  • SAP Solution Manager 7.2

The following SAP NetWeaver based products are not supported on SQL Server 2016:

  • SAP Solution Manager 7.0 EHP1 and earlier releases of SAP Solution Manager
  • SAP CRM 5.0 and SAP CRM 6.0 (also known as SAP CRM 2007)
  • SAP SCM 5.0 and SAP SCM 5.1 (also known as SAP SCM 2007)
  • SAP SRM 5.0
  • SAP NetWeaver Developer Workplace is not supported on SQL Server 2016.

Before you start with the installation, please read the following SAP Notes:

  1. Release planning Note – SAP Note 2201059 (Login required)
  2. Setting up Note – SAP Note 2201060 (Login required)
  3. Required SQL Server patches – SAP Note 62988 (Login required)
  4. SWPM Note and required Kernel DVD – SAP Note 1680045 (Login required)
  5. Central Note for SL Toolset – SAP Note 1563579 (Login required)
Requirements
  1. Windows Server 2012 64-bit or higher
  2. SQL Server 2016 Enterprise Edition
Preparation
  • SAP Software Provisioning Manager
    • See SAP Note SAP Note 1680045 (Login required) on where to download the SWPM. Please make sure to always download the latest SWPM and the SWPM that matches the SAP NetWeaver version that you want to install (e.g. for SAP NetWeaver 7.0 based products you need to download 70SWPM)
  • Kernel DVD
    • See SAP Note SAP Note 1680045 (Login required) on where to download the latest Kernel DVD.
    • For SAP products based on SAP NetWeaver 7.4 and higher, use the 7.45 DCK Kernel
    • For SAP products based on EHP1 for SAP NetWeaver 7.3 and lower use the 721_EXT Kernel DVD (only the EXT Kernel is supported)
  • Java DVD
    • See SAP Note SAP Note 1680045 (Login required) on where to download the Java DVD for the product you want to install.
  • ODBC driver
    • If you want to install a distributed SAP System (database and SAP application Server are running on different hosts), make sure that the latest ODBC driver for Microsoft SQL Server is installed on the host running your SAP application Server. See SAP Note 1902794 (Login required)
    • The ODBC driver can also be downloaded from the Microsoft Download Center
Installation
  • Install your SAP system using
    • The SAP Software Provisioning Manager SAR archive (SWPM.SAR or 70SWPM.SAR)
    • The SAP Software Provisioning Manager Kernel DVD
    • The Java DVD as described in SAP Note 1680045 (Login required)
    • The DVDs that were originally shipped with the SAP product (Export DVD, language DVDs…)
  • After the Installation upgrade your kernel to the latest 7.21 EXT/7.22 EXT Kernel or 7.45 Kernel. 7.22 EXT Kernel is recommended for SAP System based on SAP NetWeaver 7.31 or lower.
  • ABAP/ABAP+JAVA: Connect your new SAP System to your SAP Solution Manager (only required if you do not install SAP Solution Manager)
  • ABAP/ABAP+JAVA: Create a maintenance stack to implement at least (only required if you do not install SAP Solution Manager) SAP Business Suite 7i 2011
    • Update: SAP Business Suite 2005
      • SAP ERP 6.0 SPS 28 or higher
    • Update: SAP Business Suite 7 Support Release 1
      • SAP CRM 7.0 SPS 18 or higher
      • EHP4 for SAP ERP 6.0 SPS 18 or higher
      • SAP SCM 7.0 SPS 18 or higher
      • SAP SRM 7.0 SPS 19 or higher
    • Update: SAP Business Suite 7i 2010
      • EHP1 for SAP CRM 7.0 SPS 15 or higher
      • EHP5 for SAP ERP 6.0 SPS 15 or higher
      • EHP1 for SAP SCM 7.0 SPS 15 or higher
      • EHP1 for SAP SRM 7.0 SPS 15 or higher
    • SAP Business Suite 7i 2011
      • EHP2 for SAP CRM 7.0 SPS 16 or higher
      • EHP6 for SAP ERP 6.0 SPS 16 or higher
      • EHP2 for SAP SCM 7.0 SPS 16 or higher
      • EHP2 for SAP SRM 7.0 SPS 16 or higher
    • SAP Business Suite 7i 2013
      • EHP3 for SAP CRM 7.0 SPS 10 or higher
      • EHP7 for SAP ERP 6.0 SPS 10 or higher
      • EHP3 for SAP SCM 7.0 SPS 10 or higher
      • EHP3 for SAP SRM 7.0 SPS 10 or higher
    • SAP Business Suite 7i 2016
      • EHP4 for SAP CRM 7.0 SPS 01 or higher
      • EHP8 for SAP ERP 6.0 SPS 01 or higher
      • EHP4 for SAP SCM 7.0 SPS 01 or higher
      • EHP4 for SAP SRM 7.0 SPS 01 or higher
    • Update: SAP NetWeaver 7.0 SPS 33 or higher
    • Update: SAP NetWeaver 7.0 including EHP1 SPS 18 or higher
    • Update: SAP NetWeaver 7.0 including EHP2 SPS 18 or higher
    • Update: SAP NetWeaver 7.0 including EHP3 SPS 17 or higher
    • Update: SAP NetWeaver 7.1 SPS 20 or higher
    • Update: SAP NetWeaver 7.1 including EHP1 SPS 15 or higher
    • Update: SAP NetWeaver 7.3 SPS 14 or higher
    • SAP NetWeaver 7.3 including EHP1 SPS 17 or higher
    • SAP NetWeaver 7.4 SPS 12 or higher
    • SAP NetWeaver 7.5 SPS 01 or higher
  • ABAP/ABAP+JAVA: Use the Software Update Manager (SUM) 1.0 SP17 or higher to implement the maintenance stack (only required if you do not install SAP Solution Manager)
    • DO NOT use SPAM to implement the support packages
    • DO NOT update SPAM manually but let the SUM update the SPAM as part of the maintenance stack implementation
  • SAP Solution Manager 7.2 only: Use the Software Update Manager (SUM) 1.0 SP17 to install SAP Solution Manager 7.2 SR1 which already contains the required SPS 01
Post Steps

Configure your SQL Server as described in SAP Note 2312935 (Login required)

System Copy of SAP NetWeaver

You can also copy your SAP System that is running on an older SQL Server release to a machine running a new SQL Server with the following steps:

  1. Make sure that your source system is at least on the support package stack as described in the installation section if this blog.
  2. Copy your SAP system using
    1. The SAP Software Provisioning Manager SAR archive (SWPM.SAR or 70SWPM.SAR)
    2. The SAP Software Provisioning Manager Kernel DVD
    3. The Java DVD as described in SAP Note 1680045 (Login required)
    4. The DVDs that were originally shipped with the SAP product (Export DVD, language DVDs…)
  3. After the Installation upgrade your kernel to the latest 7.21 EXT/7.22 EXT Kernel or 7.45 Kernel. 7.22 EXT Kernel is recommended for SAP System based on SAP NetWeaver 7.31 or lower.

The steps for a System Copy where the source SAP system is already running on SQL 2016 are the same.

Update or Upgrade of SAP NetWeaver

Only updates or upgrades that are supported by the SAP Software Update Manager are supported for SQL Server 2016. Please read SAP Note SAP Note 1563579 (Login required) to find the SAP Note for the latest SAP Software Update Manager that describes the supported update and upgrade scenarios.

As an example, the following upgrades are not supported by SAP Software Manager and are therefore not supported for SQL Server 2016:

  1. Upgrade of SAP CRM 5.0 to SAP CRM 7.0 or EHP1 for SAP CRM 7.0
  2. Upgrade of SAP SCM 5.0 to SAP SCM 7.0 or EHP1 for SAP SCM 7.0
  3. Upgrade of SAP SRM 5.0 to SAP SRM 7.0 or EHP1 for SAP SRM 7.0