VMWare Vulnerability can cause Database Inconsistencies

SAP released a “Hot News” (SAP Note 2229228) on a significant problem using VMWare vSphere Storage APIs – Data Protection with VMWare ESXi 6.0.

Backing up a virtual machine (VM) with Changed Block Tracking (CBT) enabled fails after upgrading to or installing VMWare ESXI 6.0.  You might encounter the following:

  • Databases running inside a VM can develop inconsistences
  • Powering on the VM can fail
  • Expanding the size of the virtual disk can fail
  • Taking VM quiesced snapshots can fail

SQL Server does not contribute to this problem but it can become impacted by the misbehavior shown by VMWare vSphere Storage APIs – Data Protection.   Your database or the backup images could become physically inconsistent and have severe impacts to data availability.

 

To avoid inconsistencies caused by this problem, if you are using VMWare ESXi 6.0 move immediately to patch release ESXi600-201505001 (2116125) or later.  More information on the patch can be found HERE.  An upgradable version should be able to be found HERE.