SharePoint 2013 Crawl History Error

Just a quick one; if you’ve ever seen the error “Could not find Stored Procedure Search_GetRepositoryTimePerCrawl” when you click on “crawl history” in the SharePoint Search app then this fix could be for you. The Fix In short, you need to run the “Search Health Monitoring – Trace Events” timer-job which is likely disabled. This’ll…

0

SharePoint Search Service – Failover & Outage Resiliency

I thought I’d share some tests I’ve done on how much more resilient the new search engine is to server outages now in 2013 just because I’ve done some research on it just recently. It’s especially nice for consuming farms because there’s a nice abstraction from any server apocalypse going on in the service publishing…

0

Setup Hybrid SharePoint Online + On-Premise Search Federation – A Quick Guide

In a hybrid SharePoint world a nice trick you can do is to merge search results from your on-premises SharePoint setup with your SharePoint Online sites – i.e. you search in one place (on-premise SharePoint for example) and see results for both places in the same search results list. It’s a little known fact that…

0

Access Denied Crawling sps3 Content Source in SharePoint 2013

No User Profiles Being Crawled Another quick one. You might notice that no user profiles are being found when you search for them. If you take a look at crawl logs, you’ll probably this error in the crawl logs and think it’s related. You’d be right – no profiles & this error are very much…

2

Changing Indexer Performance Setting in SharePoint 2010/2013

Just a quick note for anyone that used MOSS/SharePoint 2007 and is wondered why the option to change the indexer performance has been removed in SharePoint 2010/2013. Well worry not SharePointer, it is still there. Where is it in SharePoint 2010/2013? It’s just moved to PowerShell – Set-SPEnterpriseSearchService to set it and Get-SPEnterpriseSearchService to see…

2

SP2013 + Win2012: Unable to retrieve topology component health states. This may be because the admin component is not up and running

I’ve just been fighting an issue with SharePoint 2013 Foundation – the search functionality specifically. Once I’d provisioned a search application via the wizard, the health status of the service wasn’t available despite the fact the administration service was started. There are known issues for using this on Windows Server 2008 R2 (http://office.microsoft.com/en-us/help/sharepoint-server-2013-known-issues-HA102919021.aspx#_Search) but this…

7