Project Server 2010 Requires MSS2010 Enterprise

For anyone planning on deploying Project Server 2010, please realize that it now requires MSS2010, in the Enterprise version specifically. The Project Server 2010 hardware and software requirements can be found here.


The trial version downloads can be found here.

Comments (0)

Skip to main content