Ritesh Ranjan

Microsoft Dynamics CRM

Ribbons disabled for a custom entity when navigation is set to an external web resource

Hi everyone,

Writing to share a strange behavior which you would have also noticed or might notice while working with a custom entity navigating to an external web resource.

Issue:

Let’s say there is a custom entity with a N:N (many to many) or 1:N (one to many) relationships with an Account entity or any custom entities. When you click on the custom entity it should take you to an external web resource. You open the primary entity with which the relationship of custom entity is defined, in this case Account entity. Then click on custom entity, this should take you to an external web resource. Now, you would want to click on the Ribbon button but you won’t be able to do that, because the ribbons are disabled.

The same issue is reproducible with Labels or an entity with an external link.

Cause:

The issue is that when the user clicks a navigation link, there is no contextual tab on the ribbon for it so all of the event handlers on the Ribbon are being detached and the ribbon is being rendered as if it is enabled.

Workaround:

We need to click on any of the OOB Navigation link and then navigate back to the Web Resource. You can now see click on any of the buttons in the ribbon. It looks like switching between OOB Navigation Link and custom web resource link helps resolve the issue.

 

Regards,

Ritesh Ranjan – Microsoft Dynamics CRM Premier Field Engineer (EMEA – Norway)