Setup Identity and Access Tools for Visual Studio 2012


There are a couple of options for installing the tools that are mentioned here

Here are the steps to installing Identity and Access Tools from the Extension Manager in Visual Studio:

    Start Visual Studio 2012.

    From the menu select TOOLS | Extensions and Updates. . .

    Click the Online extensions node in the tree view on the left.

    Search for “identity” in the search field in the upper right

    Click the Download button to download and install the package.

    image

    After the install, you will be prompted to restart Visual Studio.

    image

    After restarting Visual Studio, you should now see the Identity and Access. . . option if you right-click on your project.

     

    image

       

      Comments (6)

      1. WIF developer says:

        Does not work with VS 2012 Default MVC 4 Internet project. When I create the project and use the tool to insert WIF configurations, the system return error:

        Server Error in '/WIFWebApp' Application.

        ——————————————————————————–

        The resource cannot be found.

         Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

        Requested URL: /WIFWebApp/login.aspx

      2. rickrain says:

        Hi WIF Developer,

        If you are planning to use WIF, consider the 'Intranet Application' project template as your starting point instead.  It provides a similar UI to start with, but doesn't have all the SimpleMembership and forms-based authentication in it by default that causes issues when trying to WIF-enable your project.

        -Rick

      3. SupaHoopsa says:

        Does not work in Visual Studio 2012 – I'm getting the following in my ActivityLog.xml​:

        <entry>

           <record>502</re​cord>

           <time>2012/08/2​2 19:33:12.836</t​ime>

           <type>Error</ty​pe>

           <source>VisualS​tudio</source>

           <description>Se​tSite failed for package [IdentityAndAcc​essVSPackage]</​description>

           <guid>{97E6CB8F​-C650-43EA-A6F3​-2B4A51ECC8D5}<​/guid>

           <hr>80004003 – E_POINTER</hr>

           <errorinfo>Obje​ct reference not set to an instance of an object.</errori​nfo>

         </entry>

         <entry>

           <record>503</re​cord>

           <time>2012/08/2​2 19:33:12.836</t​ime>

           <type>Error</ty​pe>

           <source>VisualS​tudio</source>

           <description>En​d package load [IdentityAndAcc​essVSPackage]</​description>

           <guid>{97E6CB8F​-C650-43EA-A6F3​-2B4A51ECC8D5}<​/guid>

           <hr>80004003 – E_POINTER</hr>

           <errorinfo>Obje​ct reference not set to an instance of an object.</errori​nfo>

         </entry>

        I have tried three times and get the same error each time. I have left a comment here: visualstudiogallery.msdn.microsoft.com/…/1

      4. rickrain says:

        Hi SupaHoopsa,

        Your error is one that Vittorio responded to on 10/24 for another user and these steps appeared to work.  Please try these steps:

        1. Uninstall the tool.

        2. Re-install the LATEST (1.02 updated on 10/23/2012) tool for Visual Studio RTM.

        Also, please note that projects created with the RC version of the tool will *not* work with the RTM version.

        -Rick

      5. SupaHoopsa says:

        I have no idea what was different today to yesterday as I am sure I chose version 1.02 yesterday, but it has worked perfectly OK this morning.

        Thanks

      6. rickrain says:

        Excellent – glad to hear it's working for you now. 🙂

        -Rick