.NET 4.0 Beta1/Beta2 Web Application Configuration section missing declaration error


Symptoms

If you encounter the following error in your web application (things hosted in IIS) “The configuration section <sectionName> cannot be read because it is missing a section declaration " 

 

examples

“The configuration section ‘standardEndpoints’ cannot be read because it is missing a section declaration”

“The configuration section ‘tracking’ cannot be read because it is missing a section declaration”

then you need to install either SP2 of Vista/Win2k8 or the hotfix mentioned in KB article 958854.

 

I would actually recommend anyone trying out 4.0 Beta1 bits always install the hotfix below.

 

Issue

A cut and paste from the KB article

“A hotfix rollup is available for Internet Information Services (IIS) 7.0 to support the Microsoft .NET Framework 4.0. This hotfix rollup resolves the following issues that occur when you use the .NET Framework 4.0 with IIS 7.0:

    • You cannot use the IIS Manager UI (Inetmgr.exe) to manage both .NET Framework 2.0 applications and .NET Framework 4.0 applications.
    • You cannot use WMI to manage .NET Framework 4.0 configurations.
    • The managed runtime version is not set correctly in the worker process (W3wp.exe).
    • The IIS configuration system does not determine the correct managed runtime version.
    • You cannot use the IIS 7.0 command-line management tool (Appcmd.exe) to manage .NET Framework 4.0 configurations.
    • The IIS Manager UI (Inetmgr.exe) shows the .NET Framework 2.0 Provider features for .NET Framework 4.0 applications and site

 

Here is the link to the KB article

http://support.microsoft.com/default.aspx/kb/958854

Solution

 

Install Windows Server  2008 /Vista Sp2

http://technet.microsoft.com/en-us/dd727510.aspx

 

or

 

Install hotfix

http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=958854&kbln=en-us


Comments (0)

Skip to main content