Unable to find appropriate service endpoint information in the configuration object – Install Reporting Service extension Dynamics AX


When you try to install Reporting Service Extension on Dynamics AX, you might get the following error.

 “An  occurred during setup of Reporting Services extensions. Reason: Unable to find appropriate service endpoint information in the configuration object”

 

 

Why : Because the BI service is not deployed.

Solutions: try the following.

  1. Open AX > System Adminstration > Setup
                    Services and AIF > Inbound ports.
                                 Click on Activate button (select BI Services) 

 

2. you might want to delete the config file from registry.
           type regedit in the run command (Ctrl+R)
                Go to HKEY_CURRENT_USER\Software\Microsoft\Dynamics\6.0\Configuration\Original
                                    select WCFConfig and delete it

 

Try to install reporting extension now.

     the above registry key will be generated again.

Note: missing end point means a port is not opened for reporting services extension. so activating a port BIServices.(AOT > ServiceGroups > Right Click BIServices> deploy) will help

Comments (2)

  1. Trisha says:

    Thanks for posting this solution!

  2. Ravi Theja Madisetty says:

    Dear Raj,

    Even I had the same error during fresh installation, I attempted to start BI services from inbound ports but got error related to dll’s. Recreating XPPIL folder has resolved my issue.

    Best Regards.,

    Ravi Theja Madisetty

    https://techguns.wordpress.com

    https://tech-guns.blogspot.com