The type initializer for ‘<Module>’ threw an exception

Issue: when you try to launch visual studio throw command prompt you might run into the following error



Because of conflict with the .Net versions the error is thrown.


Clear the vairable complus_version or set the complus_Version to latest .NET version. In my case I changed from v.2.0.xxxx. to v4.0.30319. you can verify the latest .Net version from the folder  C:\Windows\Microsoft.NET\Framework


Comments (2)

  1. boboka says:

    can you tell us how to clear or set the complus_versio step by step

  2. RajaKedar says:

    Answering boboka:

    How to set environment variables?

    using command prompt = set complus_versio="enterText"