Heads up Vista FSX flyers – Vista multiple monitor fix now available!


There has been a known issue with Vista and multiple monitors, where trying to go full-screen with any application did not work.  A black or flickering screen was the result. Fortunately running windowed was no problem.


Customers who called in were sent to the KB page here.


Now there is a fix available here. And the KB page has been updated to reflect that.


Just to clarify, this is a Windows Vista OS fix, not an FSX fix and not related in any way to SP1 for FSX.


Edit: Here is the link for 64-bit Vista.

Comments (7)
  1. karijno says:

    Thanks Phil,

    With this KB finally i use all FSX potential with my multimonitor setup…. 🙂

    Thanks

    Fabio

  2. Tom Tanida says:

    Ah, glad to see this… thanks Phil.  I was expecting this fix in SP1 but I didn’t realize it was Vista related.  I had actually been working around it by hitting Ctrl-Alt-Del and then hitting Cancel after the screen starts flashing. ^_^

  3. noodlz says:

    Thanks for the heads up, it was really annoying to have to switch in and out of full screen mode to get it to work. Looking forward to SP1…

  4. dunc says:

    Interestingly enough, that fix does NOT work for FS2004. I still have flickering screens when going to fullscreen on two monitors. Wonder if this is the same issue, though. The screens seem to "alternate", like left right left right left… and so on…

  5. Ian McPhail says:

    Thanks for the steer.  It worked straight out of the box, so to speak,  I have three screens on a matrox triplehead 2 go, and the fourth one I use for putting pop-up instruments and ATC.  It is great to have this resolved.  Will we have to wait until FSXXI to get an algorithm in ATC that will give more logical heading changes?  Sorry, that’s off topic, the multiscreen fix is first class so thanks to the Redmond Vista team.

  6. kuyper says:

    So, I can’t tell if this happened before or after the hotfix was applied (worked great, BTW and a huge relief) but my cursor is *black* which makes it hard/impossible to find when it’s outside an active window. This may not be related to the hotfix, but really needs to be fixed.

    Nvidia GeForce 7600 GS, DirectX 10, Processor: Intel(R) Pentium(R) 4 CPU 3.20GHz (2 CPUs), ~3.2GHz

    Actually, the HyperThread issue brings up something else I noticed. FsX only binds to one thread – that one is flat-out 100% utilized whilst my other is idling along. Is this a perfmeter error or is FsX only using half capacity? Surely it’s a multi-threaded app?!

    Task Manager screenshot:

    http://s3.amazonaws.com/kuyper-pictures/CPU-util.jpg

  7. tas7 says:

    my cursor was black too – could not see it on dark backgrounds. I went and changed the settings in mouse pointers under personalization (in vista).

    I hope this helps.

Comments are closed.

Skip to main content