Power View in Excel won’t render from SharePoint

I originally encountered this issue back in May with a customer.  We had another customer this month that had the same issue.  When you try to load an Excel Document with a Power View Report in it from SharePoint, you may encounter the default unable to load power view report image. Before I get into…

2

SharePoint Adventures : Using Claims with Reporting Services

Back in February of 2011, I created a blog that walked through using Kerberos with Reporting Services. Since then, we have moved Reporting Services to a shared service within SharePoint.  This changes the game and we are now in the Claims world.  I’ve been asked a bunch of times regarding Claims Configuration, and just clearing…

7

RS, SharePoint and Forefront UAG Series – Intro

I have been working a fairly complicated case over the last year that involved running Reporting Services Reports through a Universal Access Gateway (UAG) to publish a SharePoint Site.  I worked with an engineer (Alejandro Lopez) in the SharePoint Support Group as well as two folks (Prateek Gaur and Billy Price) in the Security Team…


RS, SharePoint and Forefront UAG Series – Part 2 (Operational Reports)

Part 1 – Intro Part 2 – Operational Reports (Classic RDL Reports) (you are here) Part 3 – Power Pivot Gallery (Silverlight) Part 4 – Export a Power View Report to PowerPoint   This piece took the longest amount of time to narrow down what was going on.  This issue was when they were trying…


Invalid or loopback address when configuring SharePoint against a SQL Server

I was presented with a connectivity issue when trying to configure SharePoint 2013 using a CTP build of SQL 2014.  They got the following error when they were it was trying to create the Configuration Database. Exception: System.ArgumentException: myserver,50000 is an invalid or loopback address.  Specify a valid server address.    at Microsoft.SharePoint.Administration.SPServer.ValidateAddress(String address)   …

5

Power View display issues with Page Viewer Web Part

I ran into two separate issues this week that both dealt with displaying a Power View report through a Page Viewer Web Part within a SharePoint page in SharePoint 2013. The resolution to both were the same, so I thought I would lump them both into this post. Issue 1: Visual Artifacts while scrolling page…

1

Getting a SharePoint List Data Source to work with Reporting Services Native Mode

A case came up where the user was trying to use Report Builder in a Reporting Services instance that was not integrated with SharePoint.  It was in Native Mode configuration.  They indicated that they were getting a 401 error.  My initial thought was that we were hitting a Kerberos issue.  Of note, they were trying…

5

SharePoint Adventures : Claims, Named Pipes and Kerberos

I ran into a new Kerberos Scenario that I hadn’t hit before when I was working on the cases related to this blog post. It’s rare that I actually see a case related to the Named Pipes protocol.  When I do, it is usually a customer trying to get it setup with a Cluster deployment. …