INF: RML Utilities – You cannot use 9.01 Reporter against performance analysis database loaded by down-level ReadTrace


Summary

If you use the latest 9.01 release of Reporter and point to a performance analysis database that was loaded by a down-level version of ReadTrace, you may get errors about missing stored procedures such as the following:

“Could not find stored procedure ‘ReadTrace.usp_CheckSchemaVersion'”

More Information

The 9.01 Reporter version will not work against a database that was populated by a down-level version of ReadTrace.  The 9.01 version of Reporter depends on certain schema changes to support enhanced reporting features.

You will need to reprocess trace files with a 9.01 ReadTrace and populate a new database.

If you do not have the trace files available to reprocess you will need to use the down-level version of Reporter to point to the down-level database.

Sarah Henwood | Microsoft SQL Server Escalation Services