Compatibility and Visual Studio 2010 Service Pack 1


As with any major release, the release of Visual Studio 2010 SP1 is likely to raise questions about compatibility with existing releases, particularly the out-of-band and pre-release copies of our products. The Visual Studio SP1 team has done a lot of hard work with other teams to ensure compatibility across a wide array of products. Below are some of the more popular Visual Studio related releases and their known compatibility with Visual Studio 2010 SP1. This list is not exhaustive, but it is a good starting point for supported releases. Previous versions of the below items may not be supported – it is recommended that you upgrade to the compatible versions listed below. We’ll update this list as we find additional relevant compatibility information. 


Compatible releases with Visual Studio 2010 SP1 RTM (last updated 3.17/11): 


Known incompatible releases with Visual Studio 2010 SP1 RTM (see links for details on compatibility and workarounds):



Comments (8)

  1. Compat with VS 2010 SDK? says:

    After installing VS 2010 SP1, I tried to install the VS 2010 SDK (…/details.aspx) but it won't install.


    Error Type: Microsoft.VisualStudio.Sdk.Setup.MissingPrerequisiteException

    Error message: You must have Microsoft Visual Studio 2010 installed on your computer before proceeding.

    VS 2010 is certainly installed. (Win 7/64)

  2. Chris Lively says:

    You might add SQL Server 2008 R2 as being incompatible with VS 2010 SP1's update to the database projects.  If SQL 2008 R2 is installed and you install VS2010 SP1, then you will receive errors in visual studio anytime you open a .sql file.

  3. Doug Turnure says:

    Hi Chris,

    You are correct, there were a couple of issues with SS 2008 R2, and the SQL team is targeting mid-April with a fix. You can follow the progress via this Connect bug –…/ssms-2008-r2-is-losing-intellisense-after-installing-visual-studio-2010-sp1


    As for the other comment about Visual Studio 2010 SDK, we've had another report about this, and it is captured in this Connect bug; feel free to follow the progress here:



  4. Stéphane Beauchemin says:

    Hey Guys,

     Does anyone of you know when a version of VS2010 SP1 compatible with Windows SDK 7.1 will be available?  If not, how can we know when it will be available?

  5. @Stéphane – Hi, my name is Jennifer Leaf and I'm a Program Manager for the Windows SDK.  We released an update to the SDK today that will address the compatability issues between VS2010 SP1 and Windows SDK 7.1.  The SDK update is available for download here:

  6. Hi,

     Thanks for notifying.  I will certainly install the upgrade and then, we'll see for VS2010 SP1 as I could read many comments about problems with SP1……/developers-react-to-visual-studio-2010-sp1.aspx

     Maybe you can comment?

    Thanks again for helping.

  7. Hi again Jennifer,

     Related to the weblink mentionned in your reply, I understand that I must first install SP1 and then the KB2519277 update.  

    Any other updates issued that are related to VS2010 SP1 and that I should be aware of?

    I think I will definitely have a whole system backup before installing SP1… 😉

    Thanks again for your help.

  8. As far as the Windows SDK is concerned, no – the SDK update posted above will address the issues between the SDK and SP1.  I can't speak for the other comments about SP1 though.