Azure DSC Extension – Versions 1.0-2.3 no longer available

NOTE: For information on OS support, and other features, please refer to our release history.

Today we retired versions 1.0 to 2.3 of the Azure DSC Extension. These versions use preview versions of WMF 5.0 whose signing certificates have expired, so it is no longer possible to install them.

If any of these versions are already installed on your VMs they will continue to run, but you will not be able to install them on new VMs.

Our PowerShell cmdlet, Set-AzureVMDscExtension still uses version 1.* as the default; you can install a different version with the –Version parameter:

                                                                                                                        
PS> Set-AzureVMDscExtension -Version 2.8 …                                                                         
                                                                                                                        

Starting with the soon-to-be-released Azure PowerShell v1.0, the default will be 2.*.

If using an ARM template, be sure to update “typeHandlerVersion”:

001 

002 

003 

004 

005 

006 

"properties": { 

    "publisher": "Microsoft.Powershell", 

    "type": "DSC", 

    "typeHandlerVersion": "2.8", 

    … 

}

Feedback

As always, your feedback is important. Please feel free to reach to us posting comments to this post, or using Connect: https://connect.microsoft.com/PowerShell/Feedback.