Windows Management Framework 3.0 Compatibility Update

Windows Management Framework (WMF) 3.0, (currently distributed as KB2506146 for Windows Server 2008 SP2 and KB2506143, for Windows 7 SP1 and Windows Server 2008 R2 SP1) has been temporarily removed from Windows Update to protect from accidental installations on unsupported systems. Those who want to install WMF 3.0 to take advantage of all the great features this update provides can do so by installing the update from the Microsoft Download Center, after reading the known compatibility issues detailed below.

Background:

Windows Management Framework (WMF 3.0) was released to the Download Center on September 17, 2012. On December 11, 2012,this package was released through Windows Update. Although it was released as an optional update, many customers chose to deploy the package automatically.  Because there are compatibility issues between some released server applications and WMF 3.0, we have temporarily removed WMF 3.0 from Windows Update. This should prevent customers from inadvertently installing the package on unsupported systems.

 

Known Compatibility Issues:

Windows Management Framework 3.0 (WMF 3.0) is not currently compatible with the following applications.

–         System Center 2012 Configuration Manager

http://support.microsoft.com/kb/2796086  (Configuration Manager Management Points collocated with clients fail after installing Windows Management Framework 3.0 and running Client Health Evaluation)

–         System Center Virtual Machine Manager

http://support.microsoft.com/kb/2795043 (Managing Hyper-V hosts using Virtual Machine Manager fails with Error: 0x8033803b after installing WMF 3.0)

–         Microsoft Exchange Server 2007 and Microsoft Exchange Server 2010

http://blogs.technet.com/b/exchange/archive/2012/12/14/windows-management-framework-3-0-on-exchange-2007-and-exchange-2010.aspx (Windows Management Framework 3.0 on Exchange 2007 and Exchange 2010)

–         Microsoft SharePoint 2010

http://connect.microsoft.com/PowerShell/feedback/details/746908/powershell-3-0-and-sharepoint-2010  (Windows PowerShell 3.0 and SharePoint 2010)

–         Windows Small Business Server 2008 and Windows Small Business Server 2011

http://blogs.technet.com/b/sbs/archive/2012/12/15/windows-management-framework-3-0-applicability-on-windows-small-business-server-2008-2011-standard.aspx  (Windows Management Framework 3.0 applicability on Windows Small Business Server 2008/2011 Standard)

 

Systems that are running the above server applications should not run Windows Management Framework 3.0 at this time. WMF 3.0 is otherwise supported on Windows 7 SP1, Windows Server 2008 R2 SP1, and Windows Server 2008 SP2.