.NET Framework 3.5 SP1 installer failure on WEPOS 1.1 SP3 devices

Some WEPOS 1.1 SP3 users have reported that .NET Framework 3.5 SP1 may fail to install successfully on WEPOS 1.1 SP3. And, the user may see the error “Microsoft .NET Framework 3.5 SP1 has encountered a problem during setup. Setup did not complete correctly.”

The cause of this issue is WIC (Windows Imaging Component) failing to upgrade successfully during .NET Framework 3.5 SP1 setup. .NET Framework 3.5 SP1 installation depends on WIC upgrading successfully. This issue is the same as previously blogged for an installation of .Net 3.0 or 3.0 SP1.

If you encounter this issue, it is best resolved by using the workaround described below. Please note you have to be logged in an account with Administrator privileges on the system.

  1. Click Start, click Run, and type cmd.
  2. On the command window prompt, type cd \Windows\system32.
  3. Type regsvr32 /u wmphoto.dll.
  4. Then type ren wmphoto.dll wmphoto.dll.old.
  5. Then run the .NET 3.5 Installer.
  6. .NET Framework 3.5 SP1 should now install successfully.

– Ankur

Technorati Tags:
Comments (4)

  1. Zubiaur says:

    Just to confirm that this works on windows fundamentals for legacy pcs, this step is neccesary to intall the .net framework 3, havent tried with 4 nor 3.5 but will probably work too.

    I would thank the autor if he mentions this fact on the blog post, because there is almost no information available for us windows flp users. 😀

    thanks a lot!!

  2. Hi,

    The steps listed above are also applicable for installing .Net Framework 3.5 SP1 on devices running Windows Fundamentals for Legacy PCs.


  3. Meech says:

    THANK YOU! I couldn't figure this out for the life of me…

  4. Josh says:

    WOW I would NEVER have figured this out, thanks so much!  WinFLP rocks.