How do I connect to an Analysis Services 2000 cube with PerformancePoint Monitoring


Currently the product uses the XMLA provider to connect to Analysis Services data sources. This will result in an error when trying to connect to an Analysis Services 2000 cube. In order to connect to an Analysis Services 2000 cube, you need to manually enter a connection string in the Data Source as follows:

1. To connect to a SSAS 2000 cube, create a new Data Source and select the Analysis Services template.

2. Instead of populating the Server, Database and Roles selections, click to manually enter a connection string.

3. Enter a connection string to your SSAS 2000 cube, specifying Provider, Data Source, Initial Catalog and ConnectTo=8.0, this ensures that the 8.0 OLAP provider will be used when connecting to your cube and will ensure you can connect to the data. Below are a sample connection string and screenshot.

Sample Connection String:

provider=MSOLAP.2;data source=iwt28;initial catalog=Foodmart 2000;ConnectTo=8.0

image


 


Alyson Powell Erwin (alysonp@microsoft.com)


 


Comments (1)

  1. Parth says:

    Hi,

    I have an issue connectiong the OLAP with the Performance point,

    ServerName     :  <Server Name>PS

    Analysis Server:  OLAP.

    provider=MSOLAP;data source=EPMPS;initial catalog=OLAP;ConnectTo=8.0

    provider=MSOLAP;data source=http://epm:1000/PWA;initial catalog=OLAP;ConnectTo=8.0

    Both of the above Connection Strings are not working even i tried the connection strings:

    http://www.connectionstrings.com/olap-analysis-services

    Please help me out wih this.

    Thanks

    Parth