[Announcement] WCF Data Services 5.6.3 RTM Tools Installer Release


We are happy to announce the release of WCF Data Services tooling version 5.6.3. It enables “Add Service Reference” to work with .NET 4.5.2 for consuming OData V1-3 services. 

Previously, when you try to “Add Service Reference” for OData V1-3 service, in VS2012 or VS2013 with .Net 4.5.2, you will get the following error window with the message: “The custom tool ‘DataServicesCoreClientGenerator’ failed. Data service client code-generation failed: The element ‘DataService’ has an attribute ‘DataServiceVersion’ with an unrecognized version ‘3.0’...”

 

We have fixed this issue in the WCF data service tooling 5.6.3. You can download from Here and install it. Then, “Add Service Reference” with OData V1-3 service in VS2012 and VS2013 should work with .Net 4.5.2 and future version 4.5.X. 


Comments (0)

Skip to main content