SCOM/OMS - Failed to enable Advisor Connector on the computer.


Problem

After rebuilding SCOM and reconfiguring OMS (Operations Manager Suite, formerly System Center Advisor and Operational Insights) I started getting these errors on my client servers:

Log Name:      Operations Manager
Source:        Advisor
Date:          10/28/2015 6:20:43 AM
Event ID:      54014
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      xxxx
Description: This computer has already enabled the Advisor Connector in a different Management Group. The Advisor Connector only supports one OM Management Group.

At the same time I see this alert in the SCOM console:

However when I checked the control panel applet, I only saw only one Advisor management group listed!

 

Solution

After some research, I finally found the answer buried in a MSDN forum.  Basically OMS gets its management group information from various regkeys, not what you see in the applet.

Delete the following regkeys and restart healthservice/MMA.

  1. SYSTEM\CurrentControlSet\services\HealthService\Parameters\Management Groups\AdvisorMonitorV2 (node and subtree)
  2. SYSTEM\CurrentControlSet\services\HealthService\Parameters\Registered Connectors\{A052BD1A-7DDC-4BB1-B9F8-CEA9F31F61E7} (node and subtree)
  3. SOFTWARE\Microsoft\System Center Operations Manager\12\Advisor\RegisterToManagementGroup (value only)

Reference

Credit goes to Daniele Muscetta and his forum reply here: https://social.msdn.microsoft.com/Forums/en-US/8e0ffa61-68a0-4669-a729-ae4cd67cffbc/advisor-connector-enable-status-monitor-failed-to-enable-advisor-connector?forum=opinsights

 

Comments (0)

Skip to main content