Diagnosing and fixing Web Test recorder bar issues.


Since VSTS 2005 shipped there have been a variety of different questions raised by customers over the years.  One topic which comes up somewhat frequently is a disabled or nonexistent web test recorder bar when recording web tests.  Since it can be frustrating to diagnose and fix these problems, I’ve compiled a list of the most common reasons for this to happen and potential fixes for each.


If you know of something that fits the “My web test recorder bar isn’t working” criteria and isn’t on the list, please let me know and I’ll try to add it.


 


VSTS 2005 : Any OS : Recorder bar is not displaying when recording a webtest.


Fix:  Upgrade to VSTS 2005 SP1.   There are a few bugs preventing the webtest recorder bar from displaying under certain circumstances that were fixed in SP1.  If you're having trouble in VS 2005 and haven't yet upgraded to SP1, that's your first step.


VSTS 2005 : Vista  : Recorder bar displays, but the controls are disabled.


Fix:  Webtest recording using VS 2005 on Vista only works when running in elevated mode.  [When launching VS 2005, right click the icon and choose to run as administrator]


VSTS 2005, 2008 : Windows 2003 / Vista : Recorder bar comes up, but the controls are disabled.


Fix : the web test recorder bar does not work with IE enhanced security enabled.  (VSTS 2008 will actually display an error message telling you this)  IE enhanced security can be removed from within the Control panel / Add Remove Programs / Windows Setup


VSTS 2008 : Vista, Win7 (64 bit) : Recorder bar does not appear when recording a new webtest


Fix:  Vista caches the list of explorer bars you have available and the recorder bar was not included in your list.  The fix is to force Windows to rebuild that cache.  To do this, first make sure you have all Internet Explorer instances shut down, then open the 32 bit registry editor and delete the following keys:


HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\Component Categories\{00021493-0000-0000-C000-000000000046}
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\Component Categories\{00021494-0000-0000-C000-000000000046}


[Note: by default, the 32 bit registry editor is located in %WINDIR%\SysWow64\RegEdt32.exe]


The next time you boot Internet Explorer, your explorer bar cache will be rebuilt and the recorder bar should be available.


VSTS 2005, 2008 : Any OS : Recorder bar does not appear when recording a new webtest


Fix:  Make sure that you don’t have browser add-ons disabled.  Specifically, the web test recorder helper add-on needs to be enabled.  For Internet Explorer 7, you can find this setting in Tools / Internet options / Program [tab] / Manage add-ons.  From there, verify that Microsoft Web Test Recorder Helper is enabled.


VSTS 2008 : Any OS (IE 7) : When recording, a new web browser opens up and the new browser doesn’t have a recorder bar.


Fix:  The reason for this is that by default, about:Blank is displayed in the browser when you start recording.  This website is (by default) in the internet security zone (protected mode: on).  When you open a website in a different zone (without protected mode) it will be handled by a new instance of internet explorer.  


The fix is to do one of 2 things: a) Move about:blank into the zone where you’re attempting to record from or b) Change the default web page which is brought up when you start recording to something in the same zone as you’re trying to record.  You can accomplish this by setting the following registry key


[HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\9.0\EnterpriseTools\QualityTools\WebLoadTest]


"StartingLocation"="http://server/website"


 VSTS 2005, 2008, 2010 Beta 1 : Windows 7 : When launching the recorder, the recorder bar does not appear


Fix:  The Windows 7 security model is slightly different than previous versions of windows. (go figure 🙂   To get the recorder to show up, you'll have to run Visual Studio in elevated mode.


VSTS 2005, 2008, 2010 : IE 8 : While recording, the recorder bar will sometimes just stop working and tell me it wasn't launched from within Visual Studio


The issue here is yet again, security.  In this case, when you cross the zones defined in IE.  When you cross between different zones (by default, these are trusted sites, intranet and internet), Internet Explorer will actually kill your existing IE process and launch up a new one.  This new IE process was, as the error message says, not launched by Visual Studio and hence the recorder cannot work.


Fix:  There are multiple fixes for this problem, any one of which *should* work equally well.


1) Turn off "Protected Mode" in Internet Explorer.  (Tools | Options | Security - There should be a checkbox to enable / disable protected mode)  You'll need to reboot IE.


2) Change the initial URL which Visual Studio loads when recording a webtest to one in the same zone as you wish to record.  The regkey to do this is below.  Note that "9.0" here corresponds to the Visual Studio version you have installed.  (2005 = 8.0, 2008 = 9.0, 2010 = 10.0)




[HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\9.0\EnterpriseTools\QualityTools\WebLoadTest]


"StartingLocation"="http://server/website"


3) Run in elevated mode (I'm pretty sure that running in elevated mode will automatically turn off protected mode, so this is akin to fix #1 above.)


 

Comments (22)

  1. For anyone have trouble getting the VSTS Web test recorder to start recording properly, see Mike Taute’s

  2. For anyone have trouble getting the VSTS Web test recorder to start recording properly, see Mike Taute's

  3. oscarxie says:

    诊断和修复Web测试记录器(Web Test Recorder)问题

  4. Visual Studio Team System for Testers Content Index for Web Tests and Load Tests Getting Started Online

  5. Visual Studio Team System has some nice testing feature, amongst which is the ability to record and playback web browsing as part of a web test. The recorder makes building web tests much easier that writing the test scripts by hand. I went to record

  6. ramonduraes says:

    Solved my problem.

    Thank you

    (VSTS 2008 + Vista 64 + IE8)

    C:WindowsSystem32regedt32.exe

  7. Primarily for my own reference in the future but you may find this useful too. If you are running Windows

  8. I typically run a 64-bit OS, so I occasionally see an issue with the Web Test Recorder explorer bar. 

  9. Be.St.Blog says:

    Il Web test recorder non funziona su Windows 2008 64 bit

  10. lajos says:

    Thank You! My problem has been solved: VSTS 2008 Win7 64 bit, solution: VSTS 2008 : Vista, Win7 (64 bit) : Recorder bar does not appear when recording a new webtest

  11. Rich says:

    Still a useful post!

    My issue was with the Recorder Helper.

  12. Aleksandar says:

    Thanks, found the solution, the addon was  disabled. Probably because i start the UI recorder, who automatically disabled the recorder for web tests.

    I had this issue on VS 2010.

  13. Phil says:

    For me this really resolved the issue!! Thanks!

    VSTS 2008 : Vista, Win7 (64 bit) : Recorder bar does not appear when recording a new webtest

    Fix:  Vista caches the list of explorer bars you have available and the recorder bar was not included in your list.  The fix is to force Windows to rebuild that cache.  To do this, first make sure you have all Internet Explorer instances shut down, then open the 32 bit registry editor and delete the following keys:

    HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionExplorerDiscardablePostSetupComponent Categories{00021493-0000-0000-C000-000000000046}

    HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionExplorerDiscardablePostSetupComponent Categories{00021494-0000-0000-C000-000000000046}

    [Note: by default, the 32 bit registry editor is located in %WINDIR%SysWow64RegEdt32.exe]

    The next time you boot Internet Explorer, your explorer bar cache will be rebuilt and the recorder bar should be available.

  14. Madhu K says:

    <<VSTS 2005, 2008 : Any OS : Recorder bar does not appear when recording a new webtest

    Fix:  Make sure that you don’t have browser add-ons disabled.  Specifically, the web test recorder helper add-on needs to be enabled.  For Internet Explorer 7, you can find this setting in Tools / Internet options / Program [tab] / Manage add-ons.  From there, verify that Microsoft Web Test Recorder Helper is enabled.

    >>

    The above solution worked for me. Thanks

  15. John says:

    My IE7 browser window crashes when I start recording WebTest. I disabled lots of add-ins but still not luck.

  16. Simon says:

    I had the problem that the webtest recorder in Visual Studio 2010 wasen't showing up in IE 9.0 and by the fact was not recording anything. I got back to IE 8.0 and the recorder was back…. sigh*

  17. Madhu K says:

    <<

    VSTS 2008 : Vista, Win7 (64 bit) : Recorder bar does not appear when recording a new webtest

    Fix:  Vista caches the list of explorer bars you have available and the recorder bar was not included in your list.  The fix is to force Windows to rebuild that cache.  To do this, first make sure you have all Internet Explorer instances shut down, then open the 32 bit registry editor and delete the following keys:

    HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionExplorerDiscardablePostSetupComponent Categories{00021493-0000-0000-C000-000000000046}

    HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionExplorerDiscardablePostSetupComponent Categories{00021494-0000-0000-C000-000000000046}

    The next time you boot Internet Explorer, your explorer bar cache will be rebuilt and the recorder bar should be available.

    >>

    The above steps solved the problem of recorder bar not appearing.

    I had this problem on IE 9 running in Win 2008 R2 server machine with Win 7 OS.

  18. SB says:

    Thanks! I`ve been struggling with this problem for a while!

  19. Om Prakash K says:

    Thanks for the help

  20. Abhay says:

    I have tried Windows 7 IE9 VSTS 2008.

    Solution – Open registry by putting the following in run prompt

    %WINDIR%SysWow64RegEdt32.exe

    Delete the two registry entries while the IE is closed.

    Then It will work and it works for me

  21. javeed says:

    I have VS-2013 and Web performance test helper add on is ebabled. when i run the web performance test, web performance bar showing still disabled. what is the resolution for this.. is there any issue with 32 and 64 bit browser or with VS studio settings. can some one help me to identify the issue…and also let me know the what are the requirement for the web performance testing apart from the VS and IE helper. Thanks

Skip to main content