Vista + FireFox + Cassini Web Server (Visual Studio Web Server)


I've been having problems with this combination - pages served by Cassini take an age to load in FireFox - and I did a search yesterday and noticed Rick Strahl and others were also having problems so it wasn't just me. I've pinged the ASP.NET team and they're having someone take a look at it to try and figure out what the problem is. Of course they don't have a repro machine so I have a feeling they may be remote desktop'ing into mine... I'll let you know how things progress.

Technorati tags: , , ,


Comments (5)
  1. bbach says:

    FYI, I have had the same issue. Strangely however, it occurs on my desktop machine, but not on my laptop. The configuration of both is similar software wise (however the install order may be completely different).

    I will look forward to reading what you find out.

    Ben

  2. Which Cassini version are you having problem with: for ASP.NET 1.1 or 2.0? We deal with Cassini quite a bit and probably could be helpful if you provide more details on what kind of setup you have. We also maintain our own derivatives of original Cassini freely available for everyone interested (http://ultidev.com/Download/) with lots of bugfixes and additional functionality. You’re pretty much guaranteed to be better off using ours than the original.

  3. MikeO [MSFT] says:

    I’m using the version that ships with VS2005. I very much appreciate your offer but my concern is that we, as Microsoft, address this issue to ensure people have a great experience with VWD on Vista. I’ve been liaising with the product group and we have a repro on one of my machines that they can remote desktop to. I’m hoping we’ll be able to get to the bottom of the issue soon.

  4. Ah, sorry – I didn’t realize you were talking about WebDev.WebServer2.exe server. I thought it was about original Cassini web server sample. Original Cassini and WebDev.WebServer2.exe probably don’t’ share the same issues as WebDev.WebServer2 uses http.sys AFAIK and Cassini does not.

    So just for the record for those who visits this blog (please correct me if I’m wrong): the issue is probably limited to WebDev.WebServer2.exe only, and not original Cassini.

    Thank you,

    Vlad.

  5. A long time ago (and I do mean a *long* time ago) I posted that I was having problems with this combination

Comments are closed.

Skip to main content