How to fix building a strong type lib for CRM 7.1 (CRM 2015 Online Update 1) Errors

If your using an older version of the CrmSvcUtil.exe to generate a strongly typed lib for your projects,  you may have noticed that it seems to have stopped working against CRM Online with the 7.1 update ( carina or CRM 2015 Online Update .1 ).  Your probably seeing an error or errors that looks like…

2