ASP.NET CORE 1.0: error NU1002: The dependency System.Runtime.Loader 4.0.0-rc2-24027 does not support framework .NETFramework,Version=v4.6.1.


O ASP.NET Core teve várias alterações após a versão RC2. Uma delas é que agora, ao criar uma nova aplicação ASP.NET Core Web Application (.NET Core), apenas o framework do .NET CORE (netcoreapp1.0) é adicionado por padrão.

core

Para adicionar a versão FULL do .NET Framework ao projeto, é necessário incluir a referência ao mesmo, através do arquivo de configuração project.json, conforme:

“frameworks”: {
“netcoreapp1.0”: {
“imports”: [
“dotnet5.6”,
“dnxcore50”,
“portable-net45+win8”
],
“dependencies”: {
“Microsoft.NETCore.App”: {
“version”: “1.0.0-rc2-3002702”,
“type”: “platform”
}
}
},
    “net461”: { }
},

Entretanto, após salvar as alterações, o seguinte erro é gerado:

error NU1002: The dependency System.Runtime.Loader 4.0.0-rc2-24027 does not support framework .NETFramework,Version=v4.6.1.

erro

  

Esse erro ocorre devido existir uma dependência que não é compatível com a versão FULL do .NET Framework. Para eliminar o erro, é necessário mover a dependência Microsoft.NETCore.App, existente no começo do arquivo project.json:

 

dep

 

Para dentro do framework netcoreapp1.0, conforme:

“frameworks”: {
“netcoreapp1.0”: {
“imports”: [
“dotnet5.6”,
“dnxcore50”,
“portable-net45+win8“],
      “dependencies”: {
        “Microsoft.NETCore.App”: {
          “version”: “1.0.0-rc2-3002702”,
          “type”: “platform”
        }
}
},
“net461”: { }
},

The English post is available at: ASP.NET CORE 1.0: Multiple Frameworks Target Issues

Comments (0)

Skip to main content