LAPS updated to 6.2.0


Hello,

Tonight, we released updated version of LAPS. Changes in new version:

  • Support for localized local Administrators group name on localized OS builds when using setup parameter CUSTOMADMINNAME – you no longer need to create MST files for OS builds where name of Administrators group is localized to be able to create custom admin account during installation
  • Fix of bug “Format of path is invalid” in LAPS UI and PowerShell on Win 10 Anniversary update and Win 2016 Server, when reading and resetting the password
  • Fixed bug when some long error messages not shown in status bar of LAPS UI client
  • Font for password field in LAPS UI changed to Courier 12 for better readability of passwords

Download location did not change, so visit Download center for download

Jiri


Comments (11)

  1. Thomas says:

    Thanks for this update! Very helpful for our company! 🙂

  2. chris says:

    Hi Jiri – any update for LAPSE as well?

  3. YIP says:

    Hi,

    how can I update from 6.0.1 to 6.2?
    is it just re-deploy with the new msi file ?
    or is it necessary to update ?

    Thanks

    1. @YIP: To upgrade from previous version, just run the update installer and it performs upgrade automatically.

  4. Andre says:

    Got two issues with LAPS:
    1. it doesn’t log errors into event log – had to manually create the regeky ExtensionDebugLevel and set it to 0 (supposed to be the default)
    2. the AdmPwd Powershell commands seem to have some kind of limit in regards to number objects in an OU
    (Find-AdmPwdExtendedRights -OrgUnit servers
    Find-AdmPwdExtendedRights : The size limit was exceeded)
    This applies to all of the set/get/find AdmPwd commands

  5. Jared says:

    Thank you so much for the font change!! This is going to make our technicians very happy!

  6. Artur says:

    Is it possible to deploy LAPS with RODC server?
    I always get this error when the password is trying to be updated
    Could not get computer object from AD. Error 0x80070051.

    Both attributes are removed from RODC FAS

    1. Fernando Rubio says:

      Hi Artur
      the error you are getting is an LDAP_SERVER_DOWN one. Laps is prepared to work in environments with RODC, it will avoid them and try to find a regular writable Domain Controller. Can you check if a firewall could be preventing that communication?
      Best regards

  7. Abcde says:

    If you only upgrade the server side to version 6.2 and the LAPS client still running 6.0 will it still work? Thanks.

  8. GJHardie says:

    Please could you clarify what support is available for LAPS. That is to say, can one get support through your E.A., can one open individually paid for support cases for this, etc.

    1. Paul says:

      GJHardie,
      Premier support is available for LAPS. Just contact Premier support and they should be able to get a case opened up to assist you.

Skip to main content